Mailmerge not work

Hi, when I try to send email with mail merge, I obtain the error message that you can see after my signature.

I tried with several email account, with no luck. I’m using LibreOffice Version: Build ID:

I’m sure that I have set the username and password correctly. What is weird, is that the “test setting” button says that settings are ok, even if it remains hang on:
mailmerge img

What is wrong?

If the “test settings” says that it is ok, why I get “authetication required” error?


<class ‘smtplib.SMTPSenderRefused’>: (550, b’Authentication Required [smtp-33.iol.local; LIB_401]’, ‘<my_email_address>’), traceback follows
File “/usr/lib64/libreoffice/program/”, line 288, in sendMailMessage
self.server.sendmail(sendermail, truerecipients, msg.as_string())
File “/usr/lib64/python3.7/”, line 867, in sendmail
raise SMTPSenderRefused(code, resp, from_addr)

Don’t rely on the test. It doesn’t test authentication (it seems to even not test the smtp port) and finally it cannot test whether your provider allows mass mails via SMTP at all and other providers have restrictions on the sending machine’s hostname being a FQDN (checked on a firewall or MTA level of the SMTP server and both far beyond what the test can do).

Thanks for your reply.

The test on the port seems to work: I change it on purpose, and I got an error on “test” button.

For test purpose, I’ve tried to send 3 email by mail merge but I’ve got that error, so it is not matter of mass mail.

So, what can I do?



Your error clearly states Authentication Required and this obviously doesn’t work and your conclusion so it is not matter of mass mail comes too early, since you even cannot authenticate, which is the first hurdle to clear. So you need to fix the authentication problem first.

What are your SMTP settings (port, server)?
use secure connection (SSL)
and in the “server authentication…” button I added user name and password at the first option: “the outgoing mal server (SMTP) requires separte authentication”.
Is there anything wrong?
Is there any way to comunicate the bug related to the “test settings” to the LibreOffice developers?

OK - you seem to use SMTPS using port 465, which has a quite dynamic history (assigned to be used with emails, unasssiged and assigned to another service and re-asssigned to SMTPS in 2018). Due to these changes, I’m quite unsure whether the library used in LibreOffice supports that port (and protocol). What I can say from

$ telnet 465
Connected to
Escape character is '^]'.

is, that there is a service running on that port, but it doesn’t announce itself as an MTA while:

$ telnet 587
Connected to
Escape character is '^]'.
220 bizsmtp ESMTP server ready

announces itself as an SMTP server. Thus I’d try port 587

Wow, it works and I’m quite surprised. Thank you very much.
I was wondering how make this clear to other people that may occur in the same problem.
Thanks again.

As stated above in parenthesis … (it seems to even not test the smtp port) :wink:

For the records (according to OP’s last last comment):

To check a connection (server / ports) you may use: telnet <smtpserver> <port>. If it announces itself as SMTP server, it should work. For SSL try to use port 587 (instead of port 465, which is used for SMTPS)

Hope that helps.

If the answer helped to solve your problem, please click the check mark (:heavy_check_mark:) next to the answer.