Media (audio and video) not playing or displaying properly on Endeavour OS Linux

I am trying to make a LibreOffice Impress presentation on Endeavour OS Linux. Absolutely no playable media is working. At first I tried assigning a sound effect to an animation in Animation sidebar/Options Menu/Effect/Sound. I couldn’t get my sound to play with the preview button or on the slideshow, nor could I get any of the defaults to play. I also tried adding both audio and video to the presentation in multiple formats (i remember trying ogg, mp3, mp4 and webm) but in all cases I got a picture of a grey square with some semiquavers.

The play/pause and other timeline buttons do not work. The media player does not work with the current or any file. The media does not play when the slide is presented but instead shows the same image. The media is not corrupted and plays fine with MPV, VLC, etc.
I have GStreamer as well as the (base, bad, ugly, etc.) plugins installed on my computer. I am using a Lenovo ThinkPad T470s. Please help.

Version: (X86_64) / LibreOffice Community
Build ID: 420(Build:2)
CPU threads: 4; OS: Linux 6.7; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-NZ (en_NZ.UTF-8); UI: en-US
Calc: threaded

From your comments, I suppose you have already worked your way through this and linked pages, Media Support - The Document Foundation Wiki

I had previously given most of it and the relevant linked pages a skim read, anything in particular from those pages I should probably take a closer look at?

Not really, my Linux box died and I haven’t replaced it yet. You could look at this, [SOLVED] Multimedia within LibreOffice Impress - Applications - EndeavourOS
[Solved] No videos in libreoffice impress/gstreamer 1.0 / Applications & Desktop Environments / Arch Linux Forums but the fix here seems to have been covered