Mendeley does not work, cannot remove and cannot install

This is more of an answer to a problem I had than a question. Hope it is useful for someone. For some reason, after LibreOffice crashed (I had Writer and Calc opened) I could not use the Mendeley plugin anymore. The extension bar was shown in Writer and I could see the plugin appearing in the tools bar, however each time I clicked on any of the buttons of the toolbar it didn’t do anything. Mendeley gave me the option to “uninstall the plug-in” so I did. Afterwards, I tried to install it again but had the error message: “Couldn’t Install LibreOffice Plugin The LibreOffice unopkg utility gave the following output: …[a lot of other stuff!!” Writer still showed the toolbar even though it did nothing.

What you have to do in this scenario is to manually remove the extension (plug-in) so you can reinstall it. In order to do that have a closer look at the error message given by Mendeley each time you try to install it. Among all that text a path should appear. That’s where the extension is so you can delete it. In most cases the path will be /home/.config/libreoffice/4/user/uno_packages/cache

In there you will find two folders (registry, and uno_packages) and two files (log.txt and uno_packages.pmap).

  1. Close all LibreOffice apps
  2. Delete the registry folder
  3. Open uno_packages.pmap using any simple text editor and delete all its content
  4. If there’s anything in the uno_package folder delete it as well (but not the folder).

Now open Writer and check if the Mendeley toolbar is still there (Add-On 1 in my case). It shouldn’t. If this is the case then you should be able to install the plug-in again.

If someone else who understands more about all this reads this post and find something that’s not been well explained please correct me. This procedure worked for me and hope someone else finds it useful as well.

Thank you very much!, Iwas thinking of doing the same, and you confirmed me the way and added one step, it worked for me. Thank you!. In addition, mendeley was working in LO 6.4 and crushed, then I decided to update LO to v7.0 and the taskbar (complement 1) was appearing but doing nothing. I supposed that with new version of LO I needed to uninstall the add-on and reinstall, but it did not work. Now I made your process and it worked again (despite I need to re-insert few citations, but at least the plugin works again and in the last-stable LO version)