Mendeley error


I am using the 5.1.03 re version and latest version of mendeley but I can’t insert citations anymore, each time I get this message:
Error: An exception occurred
Message: .
At line: 776
And when I close it, this appears instead of the reference {Formatting Citation}.

I tried to upload again libreOffice and mendeley plugin but I keep getting the same problem.

Thanks for your help.

I had the same problem today, and my solution is related to the format of the file too.

I was tracking changes. When I accepted all the changes and turn the record off, it started to work again.

Hope it helps!

That looks really interesting; seems like something to inform Mendeley authors about, so they make their plugin compatible with tracking changes?

This may be due to the related bibliography database not being registered. Related help page here.

EDIT: Chapter 8 on Base in the Getting Started Guide for v4.x and v5.x includes this note:

Sometimes when updating LibreOffice to a newer version, your list of registered
database files disappears. When that happens, you need to use these steps to register
your database files with your latest version of LibreOffice.

My original answer was an outside guess as I have seen this happen. The answer here indicates the location of the bibliography database.

I have exactly the same issue as slima.
I cannot really make sense of your answer oweng. What would be the database I have to register in order to make the LibreOffice Plugin work in Mendeley?
I also updated Mendeley, LibreOffice and the plugin, but keep getting this error message:

Error: An exception occurred
Message: .
At line: 776

This started roughly two weeks ago, before, the plugin has worked flawlessly for several months.

Thanks so much for your help!

I have updated my answer to be clearer. It may still be be an incompatibility with the newer LO version.

What do you mean? It is not clearer.
Could you, please, explain it further?

I have a similar issue, trying to insert a citation from Mendeley causes LibreOffice to get stuck on “{Formatting Citation}”.
I run LibreOffice v5.1.1.3 and Mendeley 1.16.1, however, since I work on a Mac (OS X Yosemite 10.10.5), the suggested user profile path does not apply, either using the tabs in LibreOffice or through the Finder hierarchy (and the Release Notes are unfortunately not helpful).

Thanks for any help!

Hi u all…

I was having the same problem, but It seems to me that it is nether a Mendeley or LO problem, it has something to do with the file. Here is my work around:
I started from scratch a new document and copied the text as “unformatted text” then I tried to add my citations with Mendeley again and they started working, the “{Formatting citation}” thing disappeared and incited the correct citation, then just save and remane your previous document and that is it.
Hope this helps.


Same problem for me. Thanks cowboycamilo for your helpful answer. I am trying to figure out, what action did change my file, that it gives this error. Because the file worked well in the beginning. I work on my file sometimes from a Mac, and sometimes from Ubuntu, so maybe that is the reason?! Not sure yet… :slight_smile: I will do some more trials to track the problem and keep you updated :slight_smile: