Merging cells in a column in a Writer table modifies the length of the doc

I’ve removed a row from a four row single page table. I then am working through the multiple columns in the Writer table merging the cells then Splitting the cells of the column up into new equally spaced cells. On the last column in the document when I merge the cells it shrinks the table size and destroys all the spacing I’ve created. I can’t figure out why this is happening on the last column to merge and then divide up. I’ve tried changing the order of the columns but each time on the last column it has this same behavior. Your help would be appreciated. Thank you.BB2020Work.odt

Help us to help you:

What is it you are trying to achieve?

If you need cells of fixed heigth, you must set that heigth explicitly. otherwise they default to “optimal heigth”, which for an empty cell means that there is room for a single line of text. The column with most cells will then “carry the weight” and set the total heigth for the table.

Is this for some kind of form? Do you have an original which you need to adjust?

If you can share the file with us, we won’t need to work blindfolded. Edit your original question and use the paperclip tool to upload an attachment.

Thank you for the help! I’ve attached the document, I’ve been able to adjust all the columns except the last one. After I merge all the cells, and that is when the table shrinks.

What have you done? How comes that cells in column “Fr” have not the same height as the others in the corresponding rows?

Add to that you have a bad mixture of styles and manual formatting in your cells which is the most reliable way to head for formatting hell.

At quick look, your table is quite simple. It is a 9x13 table. Once created, you only need to merge 4 cells into 1 in the first column. Leave the buttons and heading outside the table.

I don’t see where you force row height to constrain the table to page size.

Hello, The table was setup with the Default Style. The previous 5 columns I merged the cells together and then split the column into 12 equally proportioned cells. It worked fine on all of them except the sixth. When I merged the cells in the “Fr” column the length of the table shrunk and threw off all of the spacing. I deleted the top row to see if that was the problem and I got the same results. If I force row height in the “Fr” column it doesn’t allow me to balance the cell sizes to line up with the previous 5 columns. Thank you

This may not be the definitive answer but it tries to address the problem.

Golden rule: don’t abuse the merge cells/split cells feature. In particular, it is not intended to force a size on the cells. Also, don’t merge cells to immediately split them. I don’t know how this translates under the hood, but I bet it surely complicates matters and may lead to instability.

Remark: when inserting a table, the Styles section of the dialog bears a misleading name. The resulting table has no “style” because there is no such concept of style in the “traditional” way for tables. Instead, theses so-called “styles” are in fact templates which are laid out (invisibly) with macros.

When you need to heavily reformat a table or if it has a rather unusual layout, use None “style”.

Back to your table. Obviously, you did something strange on your “Fr” column because I could not reset it to “standard” behaviour. It even froze my LO Writer ( if you’re interested). Some of its cells span two rows and others are set as two cells in one row! But even with “default” settings some have not the same height as adjacent rows. Even, Format>Clear Direct Formatting does not cure the split/merge conflicts.

Delete your table, it is the only way to get the table as you expect it.

In your case, create a None table with 9 columns and 13 rows.

  • Put the cursor inside the table, right-click and Table Properties or Table>Properties from the menu. Go to Columns tab to set column width. Whenever you change a column width, excess space is transferred to the column on its right, or space is borrowed from it. Consequently, proceed from left to right if you don’t want to spend your time adjusting the widths.

  • Select the first row (the one with column headings). Style it as Table Heading (this style is intended for that). Set its height with Table>Size>Row Height, making sure you uncheck Fit to size.

  • Customise Table Heading to your liking.

  • Select the rest of the table. Table>Size>Row Height to adjust row height, again making sure Fit to size is unchecked. You’ll need to iterate several times because there is no way to “occupy the rest of the page” (because pages do not exist in Writer until you need them for text flow).

  • When done, select the first group of 4 cells in the first column and Table>Merge Cells. Do the same for the other groups.

  • Select the whole table. Table>Properties, Borders tab, click on Outer borders and inner lines icon.

Now fill-in your table. Refrain from applying direct formatting, you incur the risk of ruining table layout. Use dedicated styles if your table can’t be “decorated” with the built-in style *Table Heading" and “Table Contents”. From the look of your table, you probably need more than two.

(edit 2020-05-03 only fixed typos)

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

Thank you! It worked, best to just start over and set the parameters right away. Very much appreciated.