Meta: upload images

Meta question on using “Ask LibreOffice”: Uploading images doesn’t work for me. As in this question, i get the error message “TypeError: data is undefined”. Help doesn’t help here, no FAQ, no meta forum as at stackoverflow. Is there any other possibility then post such errors in the “main forum”?

After all, the FAQ (“Still have questions?”) states that users should ask here if the FAQ doesn’t answer a issue. So, those questions shouldn’t be treated as off-topic, or otherwise, you should change the FAQ.

EDIT: same is true for attaching the image file instead of embedding it. Tried with JPG and PNG, file size between 35 and 41 kb.

What type of image do you want to upload (.jpeg, .png, .bmp)? What size of picture?
Perhaps it will be easier to place the image in a Writer document and upload .ODT?

@JohnSUN; I tried to upload png screenshots to ilustrate an answer. I made sure there are no blanks or other strange characters in the file name, but this didn’t help. The png has 40 kb, so i don’t think it’s a matter of file size,

@JohnSUN: Just tried same file as JPG (35 kb): doesn’t work either. Then, tried to attach the file instead of embedding it: Same result (same error message).

I will update Askbot to the newest release on 23 June. Hopefully this should fix this (and other) annoying bugs.

I’m curious about it… :slight_smile:

would be great - thanks in advance!

accepting the answer in the hope that this will solve the problem.

For the record (update): That works for me with Firefox, SeaMonkey, Google Chrome (on WinXP).

That works for me only via internet link (e.g.: Dropbox).

You’ve got the blues…?

The answer is a lot simpler. Upload images does not support Mozilla Firefox under Windows XP (and from the comments below many other OS x Browser combinations) :slight_smile: This is a known AskBot limitation.

Try Google Chrome, Internet Explorer (LOL) or switch OS :slight_smile:

Sorry, that’s wrong . I’m using Firefox under Ubuntu x64, not Windows XP… So it’s oviously not a WinXP issue…

Definitely wrong. Just tested with Ubuntu 12.04 / Firefox and Ubuntu 10.04 / FIrefox. Works neither.

LOL - doesn’t even work with IE (8) and Win XP… next test: Win 7 - coming soon

The final test: Windows 7, IE 9 - doesn’t work… giving up

@tohuwawohu, the fact that other combinations of OS and Browser don’t work either doesn’t make my answer wrong :wink: The AskLibO admin told me that it worked under Win7… maybe he was using Chrome

@Pedro1: Sorry for being too harsh - but let’s keep the result: Upload (and, presumably, attaching) of images doesn’t work except for certain browser/os combinations. Ok, so we’re back in good old times of “this page works best with IE 4 and 640x400, security features off”…

@tohuwawohu, I totally agree that this is absurd. But please don’t shoot the messenger :wink: I’m just trying to help people here. I’m not even affiliated TDF, LibreOffice or this site… I sent an email to one of the AskLibO admins with a link to this topic. Hope this helps :slight_smile: