Misleading message wastes time troubleshooting wrong problem

Summarizing my guess of the problem: When for some reason the media upon which the xlsx file is stored does not have write permissions, then opening such xlsx file with LibreOffice attempts to open the xlsx file as a text import.

INITIAL UNDERSTANDING OF THE PROBLEM (echos a similar closed question from 2013):

When trying to open a password-protected xlsx file with LibreOffice, it opens a “Text Import” prompt and tries to import gibberish (encrypted stuff I presume). It doesn’t ask me to enter my password.


For many years, across many computers, I have been using a password-protected Excel xlsx file to store my passwords. Until recently, I have always used Microsoft Office.

Until about a month ago, I have been using the password-protected Excel file with Excel 2013 (15.0.5249.1000) MS Office Home and Business (15.0.5249.1001) 64-bit on an HP 17-u273cl with Windows 10 Home 64-bit Version 1909 Build 18363.900.

More recently, I have still been using this file, and adding to it, and saving, on another computer (HP 24-df0037c) with Windows 10 Home 64-bit Version 1909 Build 18363.959 using only LibreOffice Calc Version (x64) Build ID a726b36747cf2001e06b58ad5db1aa3a9a1872d6.

Everything has worked well, and I have been able to open, use, and save this password-protected xlsx file with no problems, until today.


Today, I went to open this password-protected xlsx file on this 24-df0037C computer and, just like this old closed question from 2013:

When trying to open a password-protected xlsx file with LibreOffice, it opens a “Text Import” prompt and tries to import gibberish (encrypted stuff I presume). It doesn’t ask me to enter my password.

OK, maybe somehow this file has been corrupted, so I tried to open the backup file which has been copied to, but has not been opened on, this computer. Same results.


OK, let’s try opening non-password-protected xlsx files with LibreOffice Calc on this computer.

Wow, same result. Here’s a little detail from the dialog, trying to open the non-password-protected file:

That was a fail, so next, I will try to use LibreOffice Calc to save a new file in xlsx format and then try to reopen that file.

Hmmm, it won’t save, and I get this dialog:

So, my first weird observation is, I actually tried to save the file with the title “temp.xlsx” not “Untitled 1”.

I conclude somehow LibreOffice is corrupt.

I will uninstall and reinstall LibreOffice.


Uh-oh, this is worse than I thought. I went to copy this text and save it into WordPad in case the issue persists beyond a reinstall, but WordPad will not save to my data drive (drive D:), either.

The problem is obviously bigger than LibreOffice.

I will restart the computer and continue to troubleshoot.

OK I restarted the computer and everything works again. Hmmm, I wasted a lot of time troubleshooting the wrong problem. It seems that somehow, in that Windows 10 session, the 2nd hard drive (D:) lost write permissions. It could have saved a lot of time and trouble if LibreOffice had given a more relevant error message.

Thank you for LibreOffice. It’s pretty great.

Please mention a link to the anonymous “this old closed question from 2013”.

Please mention the number of bug report about this problem.

So, are you asking a question here? That is what this place is about: You need help with something related to LibreOffice, post a description of your problem and your wishes, and other users try to assist you. My reading of your entry above is that you solved your problem.

  • If you also intend it as a suggestion for the developers, you are barking up the wrong tree.
  • The developers are not able to predict every error happening on every system. If a readonly situation (write protected disk, user rights, file locking) coincides with a data format mismatch (which invokes text import), symptoms may be ambiguous.
  • If you cannot reproduce the problem, it will be a challenge for the developers to divine what happened in your case. You could try to report it..
  • Major system updates will sometimes restrict use of system resources until reboot, but something in your system might also be unstable. Make frequent backups of your important work!

Misleading question wastes time reading it.

Thank you, everyone, for taking the time to provide feedback. I’m sorry that I misunderstood, and that this site is not an appropriate location for posting detailed and accurate descriptions of a perceived problem. It won’t happen again.

referenced question perhaps that Cannot open password protected XLSX file [closed]