Missing hyphenation info Please in stall the hyphenation package for locale 'hi'

I use this LibreOffice
Build ID: 1:6.4.7-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

For the first time this message appears: Missing hyphenation info Please install the hyphenation package for locale ‘hi’
I mainly use this writer in Thai.
Could someone tell me what should I do? or just leave it there?

Do you save as .odt (native format)?

Has your document ever been in contact with Google Docs? If not, this bug is lurking for quite a long time now and affects many versions. See among others tdf#141384. For Google Docs case, see tdf#137742.

  1. Yes, I always save as .odt.
  2. I am not sure of cantacting Google Docs.

I have looked into the links but cannot come to a solution.

Now I am writing some new documents, the message changed to >>>
Please install the hyphenation package for locale “th-TH”.
Now I am using LO

Could you suggest how I can install the mentioned package or what I can do ?

The hyphenation package is installed with command apt-get (or software update utility in the control center).
Under my Fedora distro, the package is named libreoffice-langpack-th. Its name may be a little different under Ubuntu.

Open your document.
Check “Complex text layout”. The default language seems to be “Hindi” (hi). Switch to “Thai” (th).
If you click [OK], this setting applies to all new documents that are NOT derived from some document template.
If you check “current document only” and click [OK], this setting applies to the current document.
Call the dialog twice if you want to apply the language settings (Western, Asian, “Complex”) to brand new documents and the current document.
If you are working with document templates (different templates for different languages), open your templates for editing, and adjust the language settings for the current document, so all new documents start with the right language setting.
Of course, you can write in many languages within the same document, but there is always one “main language” which applies to the default paragraph style and character style.

Apology for my last question,
I just realized that the message *Please install the hyphenation package for locale “th-TH”. appears only with the files I use my past page template.
All newly created files don’t show the message.

Anyway it seems good to set the language options as you suggested:
User interface > Default-English(USA), no other option.
Locale setting> Thai
Western > Default-English(USA)
Asian> [None] as there is no option for Thai.
Comlex text layout> Thai

So my question is changed to:
How can I stop the message Please install the hyphenation package for locale “th-TH”. in the documents I use the template from my past file? It still appears after my above setting.