Mobile Use: Please improve the CSS

See screenshots.

Is this site tested on Mobile layout?

The layout is so bad. Especially, when posting the Subject input box is out of the screen when input method is active.

LibreOffice and this Site are both setup for a Desktop Computer. No plans for Mobile that I have heard of.

Main site is mobile-friendly. Bugzilla also works well in Mobile.

We should have a plan. CSS things could not be dufficult.

The issue regarding Subject input box may be some js issue on the floating window.

And if we can not do it in short-term, then why not borrow this css and js from Ask Fedora site? Ask Fefora is mobile friendly.

I just see that manually add ?mobile_view=1 resolves the problem. So the problem may be that mobile view is not properly detected?

You must have been adjusting the settings while I was testing. Now it is fixed.

I accept the problems of using office on a OS for mobiles like android etc.
But discourse is not part of LibreOffice. TDF or who ever runs this site recently decided to use discourse for the ask-site. And to use a comunication platform wich is not working well on mobile devices is a decision, where I can’t nice words to describe.

Your answer implies I should only anwer questions, when I’m at my desktop. So discourse seems to comes from discouraging? I will consider this, but at my desk I’m not paid to work for other other people than my employer…

When I use mobile_view=1 option, then it shows in mobile view correctly. However, this is not detected by default if the user uses mobile.

Worse, if I visit Ask LibreOffice (i.e. with the mobile_view option) on Desktop, then it is in mobile view which is good, but this seems cached and all my following visit to the ask site will be in mobile view.

That seems to work on my device. We’re also not using custom CSS at the moment, so I believe browser detection issues aren’t specific to this instance.

Not cached, but stored in your browser cookies; follow-up requests send that cookie hence Discourse honors the mobile view. Clearing your cookies should get you back to the Desktop version. Or just make a follow-up visit with ?mobile_view=0. Alternatively, simply click “Desktop view” at the bottom of the hamburger menu…