Modifying paragraph style doesn't change paragraph appearance

When I go into the “Paragraph & Styles” window, and right click on an existing style, and choose modify, change some value(s) and click “Apply” (or “OK”), I don’t see any changes to my document. This even happens if I choose some ridiculous value (like indent 2") that I’d be certain to notice.

If I change the values for a specific paragraph via Format->Paragraph, the changes are immediately visible.

Interestingly, if I change the actual paragraph style of an existing paragraph to the paragraph style I’d previously modified, the modifications are apparent in the paragraph whose style was changed.

If I create a new paragraph with the modified style, the changes aren’t visible if I put the new paragraphs between two other paragraphs with the modified style. If I create a paragraph where the paragraphs before and after are a different style, then the new paragraphs show the modified style.

The style is not linked with any others, and the next style is the same style. AutoUpdate is off.

It appears, according to my limited experimentation, that the modified style does not change the appearance of existing paragraphs with that style, just newly created paragraphs with that style or paragraphs whose style is changed to the modified style.

Some other notes: Most of the changes I’ve tried (that don’t appear when I make them and click “Apply” or “OK”) are in the “Indents & Spacing” tab, specifically the below paragraph value. If I change the font, and click “Apply”, that does appear immediately in all paragraphs with the style I’m modifying. Unfortunately, if I click “Reset” then “Apply” again, to get my previous font back, the changes do not appear. I have to Cancel out of the Paragraph Style dialog, and then Undo to get my original font back.

Is there something I’m doing or might have done to get this weird behavior? I thought the purpose of paragraph styles was to do exactly when I’m trying to do.

Using LibreWriter in LibreOffice 4.0.5. This also happened in 4.0.2. On Mac OS 10.7.5.

Thanks for any help anyone can offer

In my experience, what you describe is how LibreOffice (and OpenOffice before it) behaves: if you had adjusted the properties of a particular paragraph via menu, that paragraph will not show changes done later on its original paragraph style (e.g. via the Styles and Format box – F11).

Most of the time, by selecting the offending paragraphs and then double-clicking (on the Styles and Format box) or clicking (on the style drop-down – see image below) the style of interest, the desired change will take place.

However, not all properties of the paragraph might update. In such cases, mariosv’s recommendation to clear formatting, either from the menu or from style drop-down, is the solution.

Image credit: Wiebe, Andreas. “Applying Paragraph and Font Styles”.

To add to what @carnendil states, direct formatting (via toolbar or the menu) overrides any applied style. To remove direct formatting you must clear it as @mariosv indicates, and then re-apply your required style.

Have you tried clearing the direct formatting? Menu/Format/Clear direct formatting [Ctrl+M].

it doesn’t help in my case: the paragraph showing the issue has “Default Style”. This style has all indent attributes set to zero. However the paragraph has non-zero indentation exactly like the one above (it has “List paragraph” style by the way). I press Ctrl-M and indentation is still the same non-zero. Re-applying “Default style” after CTRL-M doesn’t help as well

Please can you share a sample file with the issue?, before delete any personal information.

You guys are awesome!

Thank you, that was precisely the problem, and, if I think about it long enough it kind of sort of makes sense.

Though it does make it difficult if, say, you have a paragraph in a particular style, and you put some phrase in bold. Then you want to change the style to maybe change the margins or indent. That will work on all other paragraphs in that style that have no direct formatting on it, except that one. If you have a huge document, that might be a bad thing.

Is there any way around this for the type of example above? That is, preserve direct formatting on a paragraph when a style change wouldn’t affect the direct formatting. And vice versa, changing a paragraph style would still be applied as long as it wouldn’t interact with any direct formatting that was done on the paragraph. I don’t know how this works in the great wide world of word-processing, but it seems to my naive mind a little more intuitive.

In my case, it’s a short document so I just selected the text in each relevant paragraph and did Ctrl-M as suggested, but still had to go back put some things back into bold.

Thanks again for your rapid and helpful responses!


When a paragraph or any style is not getting applied, it means you have some direct/manual formatting there. Manual/direct formatting has overriding preference, which is logically required. Hence, if you want the style to take effect, just select the para, text etc and remove all direct formatting by pressing Ctrl+M or Format>Clear Direct Formatting or you may apply default style first and then apply the desired style.
Its really confusing for the new comer to understand this. It sometimes cause hatred for using style. But, this simple thing will set it right.

it doesn’t help. See the details in comment to mariosv’s post above.

did you work out a solution to this, I am having the same problem, will

The solution that I find si selecting all the text, copy it and paste in a new document. Or selecting all the text, copy it, paste in other application like Wordpad, select all, and copy and paste in new Libre Office document. This clear all the fucking indesired styles. Hope can help :S

I had also this problem with the styles. Attempt to apply a style with defined paragraph indentation was not working and. Using the “Clear direct formatting” did not work, neither trying to apply the default style. The only solution I found was to copy and “paste as” unformatted text. It looks like the “Clear formatting” function is not working properly.

did you work out a solution to this, I am having the same problem, reformatting everything does not work for me

When desired para style is not getting applied, After pressing Ctrl+M (i.e. remove direct formatting) I keep applying various existing para styles like Default, Heading 1, Heading 2 etc and then I apply the desired style. So far it has worked for me.

With version 5.0.4 of Libreoffice, the same problem was occurring even when clearing all direct formats. The issue is that the “List Styles” is over riding the "‘Paragraph Styles’. Different styles can be selected with the icons under the “Styles and Formatting” (F11 to bring up). In my case, I needed to select the “List Styles” and select “Modify”, then select the “Default” button and Apply. After this the “Paragraph Styles” would word to set the indention since the “List Style” default is to not apply anything.