MS Office TAKEOVER - All ODF & ODS documents are now being opened in MS doc/xls and have the MS icon in IE

About two weeks ago all of my LO docs (ods/odf) started opening in Word and Excel. They also show the MS icons in the file names in Internet Explorer.

Here’s what i have done after goggling first for results first :

  1. I have looked at the Settings/Control Pane/Default App but do not see LO or MS Office in there just a reset button to reset to MS defaults.
  2. I went in to apps and changed the MS Word/Excel to the LibreOffice icon but still nothing opens in LO.
  3. I opened LO in the apps and all it had was Modify or Uninstall. I could not find LOAD/SAVE in the modify was suggested in an earlier question that was close

I have to open all ods/odf files using “OPEN WITH” from a right click and cannot open any file from the search box have to open from the IE file location first. Even after opening with LO the subsequent visits to that same file still opens it in MS Word/Excel.

Any suggestions are greatly appreciated as opening and closing 100’s of files a day it cuts into my productivity not mention how annoying.

Not sure if it was due to an update or something that I may have hit in error.

Assign files to LibreOffice

That Microsoft hijack happens from time to time. Usually it is connected to a major system update, and it happens more frequently in Windows S, it seems. Simply reassigning file types to LibreOffice does not always work. This has worked every time I tried (a significant number of times :wink: ):

  • First, in the Apps - LibreOffice entry, select Modify. In the second pane you get three options. Select Repair. Finish the repair procedure.
  • Next, reassign file types to LibreOffice. I usually go the Apps - Default apps path to reassign. The resource suggested by @Hrbrgr provides a detailed procedure for the other path to assigning defaults.
    • One step easily missed: When the option to “always open with this application” shows (bottom of the app selection list), make sure to tick it.