Msi file is NOT recognised by Win 10, so it cannot be installed. Any ideas?

Every time I try to install the ver 5.4.2 .msi I get the error
This installation package could not be
opened. Verify that the package exists and
that you can access it or contact the
application vendor to verify that this is a
valid Windows Installer package.
It appears that I need to go back to Open Office,. at least I can install/update it.

:)) That’s hilarious!

Yes, of course, you can do that, and it’s perfectly OK. No one would object that!

But the attitude is just … amusing. Well, why some failure in some version (even if we assume that the failure is on LibreOffice side, not on, say, internet connection, or a mirror hosting the installer) would mean that one cannot continue using currently installed thing and wait for the next version (due to be released next month), and instead must scream away… a threat? :)))

It’s known that some of mirrors (run by third parties) hosting the LibreOffice installers do a poor service, and so if a mirror-picking script chooses their site, you might get somewhat changed installer. Depending on circumstances, that might be simply changed extension, or even broken binary.

You might try downloading directly from official download archive, where all versions are kept. Hopefully, this would give you a correct installer.

My question does NOT contain a threat, maybe you are in the habit of feeling guilty, paranoid or both.
Secondly, I have tried downloading numerous versions of the programme without success. I will try the download archive as you suggest and I thank you for that suggestion.
I currently have the portable version running successfully, do you know of any method that I can use to put an icon in the taskbar similar to “quickstart”?

Thanks for your reply, however, the download archive doesn’t work either. I have had this problem for approximately six months and have tried as many “fixes” as I could find. This whole thing started when I updated to version 1704 and continued after I restored to the original W10. Maybe it is a typical Micro$oft stuff up.

I am no expert in computers and I have no interest in becoming one, I just want the things to work. If they don’t work and are not easily fixed, give 'em the arse. I do not have time to mess about.

  1. re: “guilty/paranoid/both”: well, why would one write about “going back to software X” on a site like this? A purely neutral question would contain the description of the problem, list what’d been tried, and ask for advise.

  2. “Portable version” is not telling much. Is it the portable version from TDF site (by PortableApps), or, e.g., X-LibreOffice from winpenpack? In the former case, I can only suggest creating a link to their top=level exe, since only it can run proper binaries inside.

By the way: please check the integrity of downloaded images, to make sure it’s correctly downloaded. The required information is available at the download page (Info link under yellow Download button). E.g., for 5.4.2 x86_64, it’s here:

Ah! That explains. It’s not the downloaded installation. It’s the result of poor explanation. Next time, please post the exact steps you do, and exact message you see. I guarantee that you start the install process, and it proceeds to some extent, but then stops half-way, and in the message it refers not to currently-installing version, but to old version. But you failed to mention those details.

This is because of upgrading/downgrading Windows ruined Windows’ install database.

You might want to do whatever you like. But that kind of thing could happen with any software happened to be installed in that time span. And it’s not the problem of the software, but of Windows’ poor upgrade process, and ultimately Windows makes this the user’s problem.

I suppose that you could need to download also the installer of the old version, and point to it when asked for absent package. Hope that will resolve the issue. If not, provide more details.

This site is as useful as tits on a bull! Delete my membership, I should have known there’d be no help given to overdone security when signing up. As my grndfather used to say, “You can’t trust the hun!”

The problem I’m having is it downloads but will not finish installing. It tells me to try again later. I’ve been doing this for several months but not getting any closer to installing the program. I’ve been using since StarOffice and this is the first time I’ve had a problem.

I think I have found my problem. I checked to see how many libreoffice install programs i had on my computer. They went back to 2013 and version 4 at least. About 20 or more programs. I deleted all except the last two. I then installed 5.4.? and it installed. I then installed the latest 6.0 and it stalled again so I deleted the last install program except the one for the 6.0 program. I again installed the last program 6.0 and it worked. It seems that the last installment programs were interfering with my installing the new program. Hope this helps anyone else having something the same problems I was having.