multiple unsuccessful installation attempts on linux-chromebook

I am using x86-64 Debian on a Samsung Chromebook Plus V2. Linux is still rather new to me, but I assumed my general computer literacy could bridge the gap quickly. After all, the first line on the LibreOffice installation instructions page is “LibreOffice is easy to install”!

I tried two methods.
First: was following the guide on the LibreOffice wiki for terminal-based installation(Installing LibreOffice on Linux - The Document Foundation Wiki). This was successful at first glance, but when I went to start the programs, the logo image would pop up for just a split second, then disappear. Of note, I did have some problems enabling Java Runtime Environment, and had to install (from what I recall) the developer version since the standard version gave me some error. Also the information on the wiki said problems were often due to out of date graphics drivers. I ensured everything was up to date on my machine, but still no success. In the end, I abandoned this installation attempt, uninstalling Linux and all apps and files on my machine before starting the next attempt to ensure a clean slate.

Second: was using the Flatpak process found here ( The last step ($ flatpak install flathub org.libreoffice.LibreOffice) appeared it would be successful, but showed the following error: “GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Flatpak system operation Deploy not allowed for user”.

To clarify, this is a personal machine, not administered by work or school.

Does anyone have any ideas? Thank you so kindly!

Thank you, Opaque, for your recommendations. Here is the result:

Again, the icons show as if it was successful, but upon trying to open any of the apps, the result is the same as I described above in the first scenario: a brief moment of opening the intro logo and then no further action.

Could it be a Java issue? Graphics issue? Something else? I am happy to abandon the flatpak method if the instructions on the wiki are more likely to be successful.

Again, thank you for your assistance!

Where arre your LibreOffice files from? From some Debian repository or from Did you really use the .deb files? Have you been root, while performaing the install.

And please don’t mix methods. Personally I do not see a need to use flatpak for LO, but if you do so, assure that all remains from dpkg installs of LO are removed.

Regarding your “flatpak” installation effort, I’m pretty sure that you haven’t been root. The error message “… not allowed for user” is pretty clear here and the description on is ambiguous and inconsistent. Try $ sudo flatpak install flathub org.libreoffice.LibreOffice

Hello - it could not be a Java issue. Java is in almost all cases only required for Base (Database Modul). How do you call “libreoffice” ? Please try on command line, to see whether any problems are being reported. Since I’m not familiar with flatpak, my help could only be limitited. AFAIK to get a list of installed flatpaks you need to run flatpak list and to run one of the installed flatpak’s you need to flatpak run <> (everything before the first “/”).

Successfully installed Java via “$ sudo apt install default-jre”.

Unfortunately, the apps still do not open. It load/logo screen flashes open for just a moment, but no further action.

Any further ideas or recommendations?

As said above JRE is / was not (!!!) the problem - please check the command line options. I have not recommended to care about JRE but to evaluate error messages which might appear on the command line. Correct Java implementation can only be set / verified, if your application starts - but we are not at that point.

Sorry, looked at your response on my mobile while making dinner and somehow skipped over the “not” despite the bold letters.

I’m still a Linux 101 user. I know there are simple terminal commands to call programs, but I’m not familiar. I’ve been opening from the chromeOS app launcher. All Linux programs are in their own folder. Please let me know (with specific instructions due to my novice level) if there is some command line magic that might help inform.

Again, thank you.

No problem at all.

I saw your screenshots above, so I assumed you are familiar with

  • Starting a terminal
  • Runnning a command

Therefore I asked to run

  1. flatpak list and (depending on the output)
  2. flatpak run <x.y.z> (while expecting that <x.y.z> is something like org.libreoffice.LibreOffice

I executed flatpak run and got the following error message.

dfyriart@penguin:~$ flatpak run org.libreoffice.LibreOffice

(soffice:13): Gdk-WARNING **: 11:03:25.227: Settings portal not found: Error spawning command line “dbus-launch --autolaunch=2b9f587e5aaf467e941b445116f5b3e6 --binary-syntax --close-stderr”: Child process exited with code 1

I’m running Version 74.0.3729.159 (Official Build) (64-bit) on an Acer r11 Chromebook.

Attempting to resolve the problem that LibreOffice starts, displays the logo for a moment and fails.

Few if any have got above libreoffice 5.2 on their chromebook. To get it you need to go to settings and enable Linux Beta. However I assume you did that! This is to do with the developers and them only wanting what they see as stable. If you type “sudo apt-get install libreoffice” into the terminal, you will get a working version. It will be 5 not 6. However I had to do this 2 or 3 times and still find issues. However, this is the best we will get for now. The other way is to install a LinuxOS alongside the chrome one. I did this and it was not great, but LO worked till the cat sat on the leys one night and deleted the entire OS! Choosing between the two, you are better off with the versiom you get by enabling the Linux Beta as you negate any guarantee if you install the alternative OS. Plenty online how to do it. People say they got LO 6 but I don’t think anyone has managed it in a way that works for the rest of us. I read you can do so if you are in Canary mode. (gives you an unstable environmrnt as you get every new update, but nit tested.) I am. I never managed to get LO 6 yet. Easier to play safe and use LO 5.