my printer will not print a spreadsheet doc, how do I fix this

I’ve tried to convert doc into other options without success

There’s no point in what you tried.
On the other hand I haven’t even a tiny clue to the issue since you only told what not happened.
Should I start with “Check if your printer is plugged” or any nonsens of that kind sometimes found in FAQ texts?
See Guidelines for asking e.g.

To be clear. I didn’t intend to disregard the questioner. I simply feel unhappy with this kind of question, On the one hand I don’t want to leave a questioner -who has a real probhlem obviously- without any answer at all. On the other hand I honestly have no clue how to help.
Well, @AlexKemp tried an answer (kind of tutorial to check for thinkable reasons) nonetheless, and I am curious if it might help.
Let ma add a remark on my situation:
I have a dated printer (kyocera FS-1030D) which has the outdated parallel-interface-connector formerly known as “Centronix plug”. To use it I need an adaptor USB to Centronix and a rather long cable. This works perfectly, but…
I don’t know for sure if the actual reason is OS-dependent, but can describe the effect:
If the printer was off while the computer started up, i cannot get a connection to the printer. I need to shut down the OS, switch on the printer, and THEN start the computer again.
Thousands of variants…

Did you check if the printer is “visible” to the computer by means of your OperatingSystem? Is there something sent to the PrintQueue if you try to print? Is there anything shown on the screen during your unsuccessful attempts?..

Hi @layton

Apologies in advance, because you are unlikely to like any reply to questions of this nature.

To my best understanding (I haven’t gone through the program code) LO hooks in to your existing printing system. If accurate, that means that there is almost nothing within LibreOffice to ‘go wrong’ during printing.

For myself (versions at bottom) I stopped using a HP Photosmart printer a year or so ago & installed a Brother LED printer & both worked fine under LO. That was because LO was installed correctly in the system, and the printer was installed correctly in the system. Thus LO was able to interface with the printer driver.

Here is a dumb set of steps to try (they are dumb because you have presented zero info for your OS, LO or printer):

  1. Load up your system plain-text editor + turn printer on; write a few lines; print it.
    Did it print? If yes then next step, else remove/reinstall the printer.

  2. Now add some formatting to those words & print again.
    Did it print OK? If yes then next step, else remove/reinstall the printer.

  3. Now load up LO Writer; paste in the plain text from the previous document unformatted (menu:Edit and/or Ctrl+Alt+Shift+V) & print it.
    Did it print? If yes then next step, else remove/reinstall LO as it is badly installed if it cannot print plain text.

  4. Now add some formatting to the previous words & print again.
    Did it print OK? If yes then next step, else remove/reinstall the printer.

  5. Now export the document as a PDF file (menu:File | Export as PDF…); print the PDF file from your PDF-viewer app.
    Did it print OK? If yes then next step, else get yourself another printer (PDFs are base-value documents these days and if you cannot print a PDF your printer is useless).

  6. Now (finally) load up LO Calc. Create a small test spreadsheet. Now perform the equivalent of all the previous steps, but on the spreadsheet rather than text, and find out where it breaks down.

The bottom line is that LO uses standard methods to create all documents. In my investigations these are often PS commands (Postscript), and that should translate transparently between screen & paper. Postscript is definitely the language used with PDFs.

A little extra:
The HP printer gave perfect prints for me.
The Brother LED is a much better printer but colour printing is not accurate (paper does not represent the screen colour accurately for some reason). That is a printer driver issue, not a LO nor OS problem.

(LO Version: under Devuan GNU/Linux 2.1 (ascii))

If this helps then please tick the answer (:heavy_check_mark:)
…and/or show you like it with an uptick ()

My apologies to everyone who took the trouble to try to help me in the absence of any useful info about my situation. I am new to this kind of help forum. I have an epson 442 x printer. I don’t have word or excel on my PC, I use libreoffice, and I had produced a calc doc to be printed. The printer when tasked to print the doc just appeared to print but spat out blank paper. I tried printing different docs with success. So, I thought that the printer doesn’t recognise the LO calc file type? So, I tried pasting the doc into a different file type? odf, html, google keep etc. nothing worked. I then took out the epson compatible ink cartridges and put them back in again (the ink levels were lowish, but OK) the doc then printed but came out fuzzy. I tried 3 times to get the printer heads re-set, but no improvement. Then the printer told me I was out of ink. (colour levels were fine but black was nearly gone). SO, I’m thick as far as computers are concerned but I get the impression that epson printer doesn’t like ‘compatible’ none own brand cartridges. So, I’ve ordered some of their cartridges at more expense, and I’m hoping that all will be fine when I plug them in. Any words of wisdom / advice would be much appreciated. I’ll try out your suggestions if the problem persists with new cartridges. Again, thanks for your help.

Well, you are new to this Q&A site, and I surely wouldn’t “infantilize” you, but…
Additional information should be added to the question editing it. Not being an answer to the question, it shouldn’t be posted as an answer. The software used here doesn’t support ongoing discussions as sequences of independent posts. Use the tool “add a comment” for replies to other contributors.
Did you read the Q&A I linked to in my first comment on your original question?
I now hope somebody else can use the additional infortmation to find a way to help you. I have still no clue. After all you told that different apps colud print while Calc could not …
Did you check your >File>Printer Settings... in LibO if it shows the correct printer driver?
(Sometimes a driver provided by the printer vendor does better than one delivered with Win e.g.)
Were there crashes that may have corrupted your user profile?

How were the >Format>Print Ranges for your Calc sheets defined? What did the >File>Print Preview show? …