Named ranges from Excel sheet was working earlier. Now it has stopped working.

Named ranges from Excel was working fine earlier. Working on Excel 2016 OpenLibre 5.0 can some one please tell me what settings need to be changed for it to work.sample_Excel.xlsx

you will see that the pie chart and the bar chart in the excel is supposed to update automatically. it is using named ranges. the same thing with formulas assigned to text boxes. (in the last page) they all worked fine last week. now it does not! :frowning:

Named ranges still work. What is the exact problem? Can you be more specific about exact versions of your OS and LO? Can you upload a nonworking example? (how to upload)

Thanks Xoristzatziki. I have uploaded the file. The same file when I open in my open libre.

LO version
LibreOffice 5.1.6.2 10m0(Build:2)

OS version
DISTRIB_DESCRIPTION=“Ubuntu 16.04.4 LTS”
NAME=“Ubuntu”
VERSION=“16.04.4 LTS (Xenial Xerus)”

Sigh. What is the “open libre”?

Then: thanks for the file; but to enable others to see the problem in the file, please provide exact steps, what is expected, and what you see. Like: “Go to steetX.C1 and put 12 there; now go to sheetY and see that chart over D12 doesn’t show 123%, like it should; instead, it still shows 321%”.

Otherwise, the file is usable in infinite ways, which puts too broad task to anyone who wants to help.

tdf#118108

When I open the file in Excel, I see that some of named ranges are invalid: specifically, Age_, Decay_but_Serviceable_, No_Decay_, Reject_. No idea if fixing that changes anything, and actually that should be unrelated, since the top two charts don’t depend on those invalid ranges.

Understood Mike. (i’ll update the questions with some more details)

Opening “manage names” dialog shows that almost all (except one:Percentage_sepcies) names have an equivalent name ending with underscore (ex:there is Reject and Reject_). The named range for those ending in underscores are all invalid. Maybe you created those names by some copy procedure, but probably MSExcel does not “like” them anyway.