Navigation Toolbar not working for table

This is about the Navigation Toolbar (View->Toolbars->Navigation), not the Navigator side panel.

I’ve customized it to show “Navigate by” in addition to the default “Previous” and “Next” controls. I set it to navigate by tables but it does not do so. The “Next” is grayed out and both controls do not work.

I then tried it with a new Writer document, with two separate tables in it. It still did not work. What am I doing wrong?

The solution cannot be to use the Navigator side panel, as I need the side panel set to Styles while I go through my tables via the toolbar. (The solution also cannot be to open both Navigator and Styles as separate side panels. I found a way to do this by somehow managing to have Styles docked and Navigator undocked, whereupon LO crashed the first time I used Navigator in this way.)

I note the Navigator side panel when set to Tables works fine. I further note that when I set “Navigate by” on the toolbar to Tables, the Navigator side panel changes to Tables if it not already set as such (and vice versa).

Details: LO on Windows 10.

I’d assumed until now the navigation-toolbar will only work with base, where you have a database cursor and a “current-record”, but maybe I’m wrong…

The Navigation toolbar is clearly fully integrated with Writer and the “Navigate by” command contains options like Footnotes that would not be applicable to Base.

On further investigation, the Navigation toolbar does not work when “Navigate by” is set to Page, Footnote, Graphics, and Headings. I have not tried the other settings. Interestingly, on some of the settings, the Previous control is grayed out instead of the Next control.

You could just add the commands To Next Table and To Previous Table to your Navigation toolbar. The Sidebar pane stays on Styles while clicking next table.

“To next table” and “To previous table” do work and provide a temporary workaround. I would still like be able to use the Navigation toolbar so that I can use the other options in the side panel

There is no general solution. Do not use Next and Previous on Navigation Toolbar.

It turns out that Next and Previous on Navigation Toolbar in Writer simply do not work. I had searched Ask LO on this before posting and did not find anything, so I assumed that I was doing something wrong. However, a searched of LO Bugzillz reveals these controls are not integrated ( and have UI issues (

I find it almost incredible that LO Writer knowingly ships with broken Next and Previous controls. I have wasted over two hours trying to get this feature to work and investigating why it does not.

You can help the developers by adding and confirming the entries on Bugzilla. Describe your exact situation, why the “Navigation” toolbar is so important for you. Possibly add a sample document where the problem can be reproduced.

Please avoid any polemics and present only the facts. The developers will thank you for it.

1 Like