Need help getting LO to find JRE in macOS Catalina

I have uninstalled, downloaded, rebooted, and reinstalled the official current Oracle JRE, the JDK, and LO 7 on macOS Catalina. I STILL get an error saying that the JRE is defective.

What do I need to do in order to get LibreOffice to recognize that the JRE is installed and valid? Help? Please?

Did you tell LO where it can find the JDK on your System?

Well, when I go to PREFERENCES > ADVANCED it sees Oracle Java 15 as already being installed and selected. There is no other entry in the window.

java -version
java version “15” 2020-09-15
Java™ SE Runtime Environment (build 15+36-1562)
Java HotSpot™ 64-Bit Server VM (build 15+36-1562, mixed mode, sharing)

which java

Is there something else that I need to tell LO to look for?

Please use the comment to reply / communicate. The answer box is reserved for answers. Either delete this non-answer or convert it into a comment. Thanks.


this is a known bug with LibreOffice version 7 and macOS - see #tdf135479

Hint: The bug report contains comment #14, which states that On install of Oracle Java SE 12.0.2, LO7 found 12.0.2 and worked fine. (can’t verify that statement, but may be worth a try).

Note: On macOS you need JDK, leave off all efforts to install JRE only (This requirement is unrelated to the bug).

Sorry for the bad news.