Never automatically create hyperlinks when pasting URL into Calc

Is there a way to avoid the auto-creation of hyperlinks when pasting URL into a Calc cell? I would prefer not to use a “special” paste function. Typically I’ll insert the cursor in the cell or in the formula box and press Ctrl-V. And it’s certainly not preferable to have to remove the hyperlinks after pasting as I rarely want them in a spreadsheet.


Clarifying my question after @EarnestAl response as I was not quite accurate in what I asked:

Is there a way to avoid the auto-creation of hyperlinks when pasting URL text into the Calc formula bar?

Click Tools > AutoCorrect Options, select the tab Options and untick the box URL recognition. Cheers, Al

NOTE: This will affect URL recognition in the other programs of LibreOffice too so you may prefer to Paste unformatted text into the cell.

Thanks. That should do it. I must have missed those as I usually turn off all autocorrect options.

If I copy the URL of this page from the address in the browser field and paste it into Calc it does not create a link.

If I copy the title of this page which has a link already embedded in it, or this url which has been turned into a link, then when I paste, as expected, the link is also pasted. It seems you are copying URLs with links already embedded.

To avoid surprises, use Edit > Paste Special > Paste Unformatted Text (Ctrl+Alt+Shift+V). This is a bit of a palaver so I always add the Paste Unformatted Text icon to the Standard toolbar.

  1. Click Tools > Customise. A dialogue window will open, select the tab labelled Toolbars.
  2. On the right, in the field Target the toolbar Standard should be selected, if not select it from the drop down list. In Assigned Commands, scroll down and click on the word Paste (make sure the checkbox remains selected), the new icon will go below this icon
  3. In the left hand large pane, Available Commands, scroll down and select Paste unformatted text and click the right facing arrow to add the icon below the Paste icon. Click OK in the dialogue.

Thanks for your response. To clarify, I am only pasting the text URL, not a combination which already contains a link. However, I see now the problem. When I paste into the formula bar I get a link, but no special formatting. When I paste directly into the cell I get no link, but I do get special formatting.