New(?) problem with Catalina

I have been successful in installing and running LO version 6.2.8 on macOS Catalina using the method described elsewhere here. But now I can’t install version 6.3.4 or 6.4.0. Here’s what happens:

  1. Download file from
  2. Run the .dmg file
  3. “Move” => Applications
  4. File gets copied
  5. From Finder window, click on Applications/
  6. Get warning message “…Are you sure you want to open it?”
  7. Click “Open”
  8. Get messaage “Verifying”
    And then…nothing happens. The Mac Activity Monitor does not show running.
    Now if I click on from the Finder a second time, I get this OS message: “The application can’t be opened”. No explanation as to why.
    Do I need to remove the prior LO version before installing a new one? Is there any way I can get more diagnostic info about the “can’t be opened” message?
    Many thanks!

In fact questions to be addressed to Apple.

Experiencing the same issue
I was running a LilbreOffice 6.0. (or so) successfully on an iMac 21.5-inch, Late 2015.

Catalina updated to 10.15.3 overnight and LibreOffice failed to load.
Updated to Libre 6.3.4 and still not loading.
LibreOffice appears in Force Quit and Activity Monitor as “not responding” while the app tries to load.
The LO app eventually gives up, but the “not responding” messages are still there.

I’m suspecting this is a Calalina 10.5.3 issue?

EDIT: Holds up hands to schoolboy error Forgot to do a simple restart before getting stressed about this as a Catalina issue. Did that. All works smoothly now.

Update: I have a workaround for this problem which might be a clue to the underlying problem. I’m posting this in case someone else has the same issue.

The failure occurs during step 3 in my original post. This is where one “moves” the file to the Applications folder. Note that, at least in my case, there are two Applications folders. One is at the “root” level on the boot volume, the other folder is under my user name. Moving the file to /Applications solves the problem. Fortunately, Launchpad looks at both Applications folders.

My theory is that Catalina enforces extra security on the root Applications folder. I tried to change the privileges on that folder to read+write for myself but could not do so, even though I am an administrator.

The unresolved question is why LibreOffice has this problem but not other apps.