New Windows 11 PC, Calc freezes

My old desktop PC running Windows 10 developed a hardware fault so I got a new PC from Dell. It was initially running Windows 10 PE but upgraded itself to Windows 11 PE. I restored my backup data and installed Libreoffice (x64). When editing spreadsheets, Calc has now frozen a couple of times. Windows has shut it down without crashing the whole system. The first time the spreadsheet was automatically recovered when I reopened Calc with no loss of data. The second time I was in a hurry so I opened the spreadsheet with Excel, which opened it without comment.

1 Like

In which file format do you save?

Open Document .ods

First steps to take before submitting a bug

Maybe something went wrong during or after the installation.
General Installation Issues (Windows)

Possibly a alien antivirus program might not be your friend.

Do you have all the necessary permissions for the paths you need?

To clarify the problem: This is not about Calc failing to open or freezing during opening. Calc opens normally and will open an .ods spreadsheet and allow viewing/editing as normal. But after some time the Calc window freezes and nothing within Calc responds to the mouse or keyboard. Other Windows programs continue as normal. Calc can be forced to close, or after a period Windows automatically closes it. If Calc is restarted, it will recover the spreadsheet. If the lock file is deleted, the spreadsheet can be opened and edited by Excel without comment.

Compatibility problem?

Please report the behavior also as an error in Bugzilla .

See also:

How to Report Bugs in LibreOffice .

Please post the link to the bug here.
format: tdf#nnnnnn (use only the number, not the link)
To do this, edit your original question. Thank you very much.

I have found a way to cause/reproduce the problem. I have a spreadsheet of orders with 450 rows. If I scroll up and down from the bottom to near the top and back again very fast with the mouse looking for an order, after three or four journeys up and down, then Calc freezes and has to be terminated.

Can you provide this file, then upload it here.

To do this, click on the three dots or the pencil or the edit icon under the initial question.
What is available.
In the edit mode of the question select the “Upload” icon.
Select your file and click the “Upload” button.
Thank you very much.

Sorry but the file contains private information, it cannot be uploaded.

Sorry, then my help ends here.
Maybe someone else can help you.

Sounds like a graphics issue to me. See step 5 in First steps to take, New Windows 11 PC, Calc freezes - #4 by Hrbrgr

Maybe, try Force Skia first, if that doesn’t solve it then untick Use Skia for all rendering

To expand a little, your graphics card might not be up able to take on extra work. If you were using LibreOffice or earlier before you upgraded to your current version then your graphics card might have been in the deny list for OpenGL, in other words, it wouldn’t let your card do extra work. In version 7 OpenGL is replaced by Skia but as it is still fairly new not every card will be in the denylist so you might have to disable Skia in the Options dialogue

@David.Cheshire, can you anonymize a copy of the file, re-test and upload that copy?

@ EarnestAI : Interesting information, thank you - but this was a fresh installation of LO on a new PC.

@ BigRAI : I don’t have access to that PC until the New Year, but then I will upload a test spreadsheet.

Sorry, I misread. The fix still applies.

Has this been solved? I am facing a very similar issue, freezing on rapid scrolling in either calc or writer. I am currently using version

@willylund I don’t know if original poster took the advice or not.
For you, if it freezes during scrolling then it is probably a graphics issue. In the steps I have above tick the box Force Skia software rendering.
Only if problems still arise then untick Use Skia for all rendering

My thoughts as well. I have been using LO for over 10 years now and this is the first time I have experienced anything like this. For the time being, I have enabled hardware acceleration and the “quirky” count of the graphics test dropped from 53 to 31. FYI on my Win 10 Desktop (running, the quirky count is 51 and I never had an issue. Time will tell. Thanks