[Newbie question][Writer] Custom special character list

Hello. I’m new to Libreoffice but really like it. The way i can write formulas is really easy and much easier than on Microsoft Office.

However, i still hate the way i can enter special charater (as i hated on Word, i hate on Writer). It would be nice to have kind of custom list of special characters in Special characters window. The literally lifesaver feature, however, is while creating formula, the %pi or %psi shortcut. I’d like to have one for other special characters as well. The % trick didn’t work on Rho symbol for example. I’d like to add it so it would be %rho . Is it possible?

The bonus question is, when i type Re in formula, it will change those two letters into something like this. Can i disable this “correction”?

The Math Guide explicitly states that Greek characters are designated as %-notation in two forms:

  • %-lowercase_name

Thus, to get rho letter, you must type either %rho for ρ or %RHO for Ρ. Your %Rho is mixed-case and not recognised as a valid form.

Bonus answer

The appendix in the Math Guide lists the names which are converting into math symbols. Among these, re stands for the real part of a complex number. If you want this sequence as a literal part in your formula, quote it as "Re". To format it as a variable name, encode it as italic "Re".

PS: I changed your “formula” tag into “math” because formulas are set in the Math application of the LO suite.

Thank you. Found that guide but didn’t find where and even if i can add custom notations there. Unfortunately, %rho didn’t work for me (see this image). The weird part is, the %RHO works just fine.

To the bonus part, yep, that worked well. Thank you for letting me know!

To help diagnose issues, always mention LO version and OS name.

Those are info about my libreoffice:
Version: (x64) / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: sk-SK (sk_SK); UI: sk-SK
Calc: CL

Can it be caused by faulty version?

No. Same version here and casing works fine.

%name symbols are provided to compensate for Math limitations. This application has not been updated for ages and is not at the same maturity level as the others. You are then constrained by what your keyboard can generate, plus %names and some keyword transformations like re → ℜ.
To circumvent this limitation, you can copy/paste any Unicode character from another utility. For example, under my Linux OS, KCharSelect allows me to view any character, select it and paste it into Math.

What do you mean by this application? Writer as whole or?

Math, the formula editor

You might have made some inadvertent changes, possibly in Tools - Symbols - Edit. Just scrolling in the edit box can change the symbol name if you OK out. Try setting it back to the screenshot below (from virgin installation). I think selecting ρ in the special character of Math then clicking Edit you will be able to click on ρ character which will show in Symbol Ux03C1 then click the drop down arrow to at the right to select “rho” from the list.
Disclaimer: I haven’t tried changing symbols or Symbol sets, just observed effects before cancelling out.

If all goes badly, you might want to test reverting your user profile to factory by command line or use the wizard in Help > Restart in Safe Mode > Continue in safe mode, see LibreOffice user profile - The Document Foundation Wiki for details and for effects on other parts of LO

Thank you. This might help but as i’m unable to get there (there’s no Symbols option in Tools bar), i couldn’t reproduce it.

The thing i tried is to manually add that Symbols option to Tools bar by Tools → Customize… → searched for “Symbol” in the left site. There was two functions actually. One with command .uno:InsertSymbol and second with .uno:CharmapControl, which, i think, is the one i want. So i added it to Tools tab, hit OK and…It showed up only in context menu version. In the “bookmark” style of functions, it didn’t show up. By bookmark i thought this:

But it is visible in context menu as the last option that i added:
This image (can’t add second screenshot directly as the rules for new users hits…)

When i click on it, nothing happens. I’ve seen literally none sign of action. Is there something like Log or anything to see what happens?

PS: Yes, i restarted the Writer but without luck.

Math is not part of Writer; I’m talking about Math.

Well, it is. Kind of. I can enter formula and from there, Math UI is opened. This means by this step i’m able to do what you described.

I found Rho and turns out the Rho symbol is defined as ro. This means i actually need to write %ro to enter the Rho symbol. Can i edit it so instead %ro i’ll write %rho?

PS: this change could be caused by automatically selecting my preffered language grabbed from system language. In my language, the Rho symbol is spoken as Ro (without the H) so this may be the cause of confusion.

To avoid confusion, for the purposes of Math ρ is rho, while Ρ is RHO
You found the Edit Symbols dialogue OK?
Select the rho symbol, in the Symbol field enter rho, check that the change shown graphically in the bottom left is correct, then click the Modify button then OK.
Method tested and works as described. Cheers, Al

BTW you can open Math as a standalone program from the launcher and save as .odf, or insert a formula into Draw or Calc as OLE object the same way as OLE object in Writer.

I found it earlier today. On this site they described it pretty much okay-ish. But yeah, what you wrote is basically the same thing with better explanation! Thank you for that!

Marked as solved.