"No Java installation could be found" error

I have found other posts about this. I don’t really understand the ins and outs of this though. I’m using LO Base 5.1.5 64 bit. Trying to learn about using this database for the first time, but not doing very well.

I’m guessing that “JRE” is what Java describe as “Java”, or is there some other type of Java I need?
Someone said by installing 32 bit & 64 bit would solve the problem? I’ve tried that, but I still see that same error.

The error details are: “SQL Status: HY000
No Java installation could be found. Please check your installation.”

This exactly same question comes up over and over, but seems like TDF doesn’t care to mention it unless it comes up in a place like this.

You need a JDK, JRE ain’t enough. You don’t mention your OS, but I’m gonna assume Window$. From http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html download u102 for Window$ x86 and x64, then install the x86 (32-bit) first [1], and then try x64. If nothing comes up as a warning of the system not being 64-bit, then install it just like you installed the 32-bit one. Be sure to install the 32-bit first.

[1] If you’ve already installed u102 JRE of either bit width, then unmark the JRE during installation. Be mindful of which bit width of JRE you installed so that you have both bit widths installed on a 64-bit system.

Penname is on a 64 bits system, so can skip the 32 bits part.

JRE means Java Runtime Environment :{, thanks to Rautamiekka. With it you can execute Java programs, but you can’t use it to make Java programs.

You should tell us that you are on a computer running some version of Windows (exact version, like XP, Vista, 8 or 10 required). I assume that you aren’t on Linux or Apple. If you are, then tell us so.

The thing to remember here is that nowadays computers can process data in chunks of 32 or 64 information units (bits), and programs that work together need to work with the same amount, so both should work with 32 bits, or both with 64. So as you have LibreOffice 64 bits running on a Windows version with probably 32 bits Java, LibreOffice won’t be able to use that version of Java. In fact, to make sure you don’t mess up your computer big time, Libre is made so it can’t even find a JRE made for the wrong amounts of bits. You will need to go to the Java website and download a 64 bits version. I found that was rather tricky, if you’re a novice, you may want to ask a friend to help you.

EDIT: When Java has been properly installed, open LibreOffice, select Tools - Options - LibreOffice - Advanced, tick Use a Java runtime environment and select the version you want to use in the box below by clicking the open circle at the far left on the same line as that version.

Java Runtime Environment.

Thanks for the replies. I don’t want to sound ungrateful for something that’s free, but from what has been said it seems there’s a lack of clear explanation from LO about something that’s quite involved, needed to get Base working.

Well I installed the 32 bit option first, but it made no difference. So then added the 64 bit option next, still wouldn’t run - still the same error message. I rebooted, just in case, still no luck.
Files d/l and run: jdk-8u102-windows-i586.exe, jdk-8u102-windows-x64.exe

Any suggestions of what to do next?
Btw, yes, I’m running windows 7 64 bit, forgot to say that.

Merge this non-answer to the opening post, then delete this.

Have you selected the new JRE in Tools - Options - etc.?

Whoa! Thanks for that suggestion. I’ve got past the error now and it’s offering me options to design a table.
I had absolutely no idea Base wouldn’t work straight off, I also had no idea about Java, JRE, JDK, or what they are. I just followed your clear instructions (plus your additional bit about selecting the correct Java option)
I’ve been using LO for a few years already, but not Base.
It’s always easy when someone else knows where you’re going wrong! Thanks again.

If the @florisv answer solves your question please tick the :heavy_check_mark: in it.

Hi, I can not find “JRE in Tools - Options - etc.” in the Version: for Mac. Any ideas? Thx

For the Mac you should try Preferences under the Apple menu.