No visual space before dash

Software: LibreOffice 7.2.5 Writer
OS: Windows 10
Font used: Calibri Light

When I try to type in text like git branch -m name there’s visually no space between branch and -m. To see space between them I need to type space twice.

Problem is I need to do both:

  • Visually look at the text and be able to tell that there is a space before dash

  • Be able to copy text with only one space between branch and dash

Right now it’s not possible, because either visually space is not visible or two there will be two spaces before dash.

I attached screenshots how it looks with one and two spaces before dash.

According to the View>Formatting Marks enabled screenshots,space is present in your text. That the space is rendered too narrow may be a consequence of kerning tables in the font itself. Edit your question to mention the name of the font used. Also, attach a sample file so that I can have a look at it.

When I write such technical documents with code examples, I choose a monospaced font for computer “citations”. I created a custom paragraph style derived from Preformatted Text for this usage (I named it Computer sample).

Yes, you’re right. I switched from Calibri Light to Calibri font and space before dashes became more noticeable.