non-LibreOffice document hyperlinks no longer working (ubuntu)

Suddenly hyperlinks to non-LibreOffice documents are no longer working.

I tried checking and unchecking “Ctrl-click required to follow hyperlinks” inside Tools/Options/Libreoffice/Security/Security Options and Warnings.

Internet hyperlinks, Mail hyperlinks, New Document hyperlinks and Document hyperlinks to local files with Libreoffice associated extensions (I for now only tried .odt and .ods) DO work.

I haven’t tried all file extensions, but for those I tried (basically for now .txt, .doc, and .avi) document hyperlinks didn’t open. I also only tried with links to local files, but I guess behavior will be the same for links to network files.

The issue is present in both Writer and Calc. I haven’t checked other LibreOffice apps, but I suspect the issue is common to all my LibreOffice apps. I have no issue in producing and opening document hyperlinks in other installed applications (I tried Abiword).

This is my version information:

  • LibreOffice version:
  • Ubuntu version: Ubuntu 18.04.2 LTS
  • Linux kernel version: 4.15.0-46-generic x86_64

Any ideas of what I can do to troubleshoot this? Thanks!

Fyi, the issue is now no longer present.

This is my current (different!) version information: LibreOffice, Ubuntu 18.04.2 LTS and Linux kernel 4.15.0-47-lowlatency.