not able to print labels in mail merge

Using Libre Office
I was trying to print labels in mail merge and I tried on two different computers
When going to the Mail Merge, it would go to page 4 but not skip page 5 and go on to page 6.
Clicking the NEXT button would not do anything. Finish gave me the label sheet but only with the Field info and not the information from the data base. Viewing the Data information showed the right source.
Tried from a few different data bases but with the same results.
I downloaded Open Office 4.1 and printed the labels with ho problem.
I had used Open Office before but had changed over to Libre Office.
I am disappointed that I could print labels by Mail Merge in Open Office but not Libre Office.

I can’t believe no one has an answer to this question.
I downloaded the latest version of Libre Office,
I get the same results as above.
WHAT? Is no one working on this?
Does no one else have this problem?
13 views and 0 answers.
Maybe I’ll just stay with Open Office.
It works!!!

I have the same problem. I only use this once a year to print labels for Christmas card addresses. After not being able to print labels last year, I use Open Office and it worked fine. Open Office and Libre Office are close to the same. I guess I will have to use Open Office again this year since it appears no one answers the questions on this forum.

Yes I have bumped into this problem. It used to work. Fortunately I found a post which said downgrade to LibreOffice 5.0 I was able to do that and it all works fine again.
Does anyone know if it works with 5.4 before I update?

Supposedly you need to uncheck a “Insert personalized salutation” checkbox on the page to proceed? If it’s checked, then the fields must be matched before proceeding… or did I understand you wrong?