Not responding: waiting on splwow64.exe (Print driver host 32)

I just downloaded LO and I used it for some time (maybe 30min), and after a while it just froze(not responding).

So, then “LO is not responding” pops out. So I press “view problem details”

Problem Event Name:	AppHangXProcB1
  Application Name:	soffice.bin
  Application Version:
  Application Timestamp:	52177863
  Hang Signature:	0463
  Hang Type:	128
  Waiting on Application Name:	splwow64.exe
  Waiting on Application Version:
  OS Version:	6.1.7601.
  Locale ID:	3081
  Additional Hang Signature 1:	0463e4f395c8edf797673164bd5b2680
  Additional Hang Signature 2:	4ae0
  Additional Hang Signature 3:	4ae0a0410b7cb54fdfcf0fc60ad7a454
  Additional Hang Signature 4:	0463
  Additional Hang Signature 5:	0463e4f395c8edf797673164bd5b2680
  Additional Hang Signature 6:	4ae0
  Additional Hang Signature 7:	4ae0a0410b7cb54fdfcf0fc60ad7a454

The next thing I notice is that “Print driver host 32 has stopped working” pops out.

Problem Event Name:	APPCRASH
  Application Name:	splwow64.exe
  Application Version:	6.1.7601.17514
  Application Timestamp:	4ce7b4c8
  Fault Module Name:	ntdll.dll
  Fault Module Version:	6.1.7601.17514
  Fault Module Timestamp:	4ce7c8f9
  Exception Code:	c0000005
  Exception Offset:	0000000000018e3d
  OS Version:	6.1.7601.
  Locale ID:	3081
  Additional Information 1:	abcc
  Additional Information 2:	abcc8f7853b48d9807d6d51eb1fa5df9
  Additional Information 3:	abcc
  Additional Information 4:	abcc8f7853b48d9807d6d51eb1fa5df9

So, while I was writing my question here, LO “unfroze”(I think it might have happened after I closed “print driver host 32” tab).

So, how do I fix this?

What is you operating system version and name? It looks to me you have a printer problem not LibreOffice problem. Do you notice this problem using other programs too?

Windows 7 ultimate 64-bit. Yes, I tried Office 2007 and 2010 professional, ultimate, enterprise and OpenOffice, and the result was pretty much the same.

P.S. 5min ago I’ve tried running LO in safe mode, and I had no problems

This sounds like bug fdo#66674.