Npm required to build loleaflet, but not installed

Hi everyone,

I’ve tried to build LOOL and when I do the “configure step” before the make command the process return an error related with NPM.
The configure command used by me is:

./configure --enable-silent-rules --with-lokit-path=/home/user/libreoffice/core/include --with-lo-path=/home/user/libreoffice/core/instdir --with-poco-include=/opt/poco/include --with-poco-libs=/opt/poco/lib

I had to build the POCO package because libpoco-dev and nodejs-dev were incompatible, that is, I couldn’t have both installed at the same time so, I installed version 1.9.0 (stable) of POCO from

But, now I’ve had this error below:

checking POCO version... OK
checking If we need to link with -lpcre... Yes
checking for npm... no
configure: error: npm required to build loleaflet, but not installed

I searched about this issue and I think that I’ve installed all dependencies needed to npm (maybe more than as needed) but there is still the error.

The packages installed are: nodejs, nodejs-dev, nodejs-legacy, node-ansi, node-brace-expansion, node-express, node-glob, node-global-modules, node-global-prefix, node-gyp, node-json5, node-npm-run-path, node-npmlog, node-websocket, libjs-node-uuid

Could someone help me with this issue?

Thanks in advance

NOTE: My distro is Debian 9.4

Problem solved!

If someone has the same problem, this page help me a lot to understand and solve the error:

Basically this commands below result for me:

curl -sL | sudo -E bash -
sudo apt-get install -y nodejs

But if you have 2 versions of nodejs installed can need to manage the priorities of this packages. Well, on the link above you can see a better explanation of this problem.