Nudging selected objects with arrow keys?

In Draw, how can I use the arrow keys to “nudge” selected objects (move them one pixel at a time)?

Under Resizing and Moving Frames, Objects With the Keyboard", your documentation says:

To move a selected frame or object,
press an arrow key. To move by one
pixel, hold down Alt, and then press
an arrow key.

But when I hold Alt and press an arrow key, it moves the whole view, not the objects. What am I doing wrong?

Never mind—I’m giving up and uninstalling LO. I find both Writer and Draw way too unintuitive. Their outdated GUIs and over-picky functionality require way too much fussing to be practical for me (and I’m a tech writer!).

I kept looking here for an answer to my question, and found this similar question, with a wackily geeky answer:

(Q.) How do I reduce the amount of
“nudge” when I move objects with the
arrow keys?

(A.) The amount that an object in Draw
is moved, is a factor of the scale of
the drawing e.g., Tools > Options… >
LibreOffice Draw > General > Scale
section. By default this is 1:1 and at
this scale these are the different
movement amounts:

Cursor key, unmodified: 1.0mm /
~0.04in / ~2.8pt

Cursor key + SHIFT:
10.0mm / ~0.4in / ~28.3pt

Cursor key + ALT[1]: 0.26mm / ~0.01in / ~0.74pt

At a scale of 1:2 these amounts are
doubled, while at 2:1 they are halved,
and so on.

Yikes! This seems like a good example of how this project may be neglecting the mainstream.

Fortunately, there are other free, friendlier MS Word-compatible word processors and vector-based graphics apps. I just thought I could save some time by installing LO and having both at once. Thanks anyway!

Giving up only 5 hours after posting? It’s hard to understand why anyone would be so impatient. I agree with everything @Lupp wrote in his answer. You are certainly free to choose other software, but this question and answer show that you either are not familiar with this site or not respectful of the standards of this forum.

Quoting @Ander:

What am I doing wrong?

Among the things you are doing wrong are:
-1- Ask a question without giving relevant information. An issue like the one under discussion here may easily depend on the OperatingSystem or/and the version of LibreOffice. An x.0 version e.g. should not be expected to be extremely well bug-fixed. See also the answer by @Jim K to his own question here, e.g.
-2- (Most likely but not for sure:) Against what next to every software with a GUI assumes “intuitive” try to select an object by hovering over it instead of clicking on it in a way that it shows to be selected.
-3- Enter a software-forum as a new user and, without having anything contributed, teach all the others how things should be. Moreover doing this as if developers were addressed here while actually users (mostly experienced) are.
-4- Adore the mainstream without considering if it’s goeing a good and promsing way. Question of this kind cannot be seriously discussed in this place.
-5- “Keep looking” for a short time and then assume to know enough.
-6- Show a lordly attitude.

For me the “move by smallest amount” with Alt+ArrowKey works reliably on any object handled as a shape (may also be a frame or an OLE-embedded object) in Draw and in Writer as well. My current version (for testing) is V6.0,3 on Win 10.)

It’s funny how even the criticized answer provided in this thread solved my problem. Use the Alt+Arrow Keys. If I run into any scaling issues I’ll be sure to try the “wackily geeky” answer which also looked quite useful, well explained and easy to follow.

Thanks @Lupp.


Not a solution, but I have the same issue with LO 7.0.3 Writer on Linux (on a chromebook). Il was perfectly to do ALT+ARROW horizontally (pixel by pixel), but vertically, it is scrolling 1 page instead.

Would you have a solution ? I tried also to force the position manually in the properties box, but I have access to the heigth and width, but not to the position X and Y.

As you say, this is not a solution.

So please, abide by the site rules and use the more link (only you as answer owner can see it) to repost as a comment under the question.

If the automatic procedure doesn’t work, add a comment under the question and delete your “non-answer”.