Numbered list with variable lettered sublists in writer

Does Format > Bullets and Numbering > Outline not suit your requirements?

After pressing Enter, Tab to increase indent and change to lower level, or Shift+Tab to decrease indent and go up a level. You can modify an outline to suit if it isn’t what you want, look at the Customise tab

Have you downloaded a copy of The Writer Guide from English documentation | LibreOffice Documentation - LibreOffice User Guides

1 Like

Heh, why? there is this:

So we have a teacher here, not a student; thus study is not among the required skills.

(Sorry for the snark tone. I would not do that, if the question was not asked with the strong claims that something is impossible, without any doubt, so it was not a real question like “How do I”, but rather “how dare you create such a nonsense suite”.)

1 Like

I’ve read the guide and used the suite for a number of years. Your “snark” however didn’t help at all. Ordinary users like myself do find frustration quite often at the incessant “studying” required to relearn to use devices which our era demands, as each week or month every bit of software is “improved” with “updates” that render long-sloggingly learned methods obsolete You see? Some of us LOVE reading; but tend towards history, philosophy, social sciences, literature, you name it. But software manuals and fighting with updates that force earlier formatting to fail make that impossible at a higher and higher rate of frequency to where life consists in forced labor with those dull, repetitive activities both in and outside of our working lives. We lose our freedom this way. Unpaid labor for using software required at our jobs prevents us from finishing the tool work and makes enormously tedious demands on our time.So perhaps that bit of explanation will help clarify and assist you in understanding how the unnecessary-but-inescapable demands of the dominance of digital gadgetry have this among many human costs.It seems that you dislike teachers, which is common nowadays but a shame. Your disdain definitely shows and has consequences for the person who rejects becoming educated too, unfortunately. All the same, I’d recommend that you try to resist using this forum as an outlet for exposing that mood disorder. If you don’t like the tone you perceive in a question, you can always not answer I think, and leave it to someone who is willing.

Just don’t update. Is that what you expect to hear for the complaint that things change? (And you seem to have expectations about the world that you live in, that don’t match this world. This is not something that this forum can help with.)

Otherwise, your comment - and your frustration - is completely irrelevant, and trying to express frustration when asking for help is just counter-productive. You may be frustrated however you like; but when you go and ask a question, you must realize that others don’t care about your emotions; they may be kind enough to want to help, but abusing them as your psychologists is … well, abuse.

I believe it is you who began this exchange that you now say is “abuse.” The program is resisting the layout I saved and removing it.
So if you know the answer as to why that has been happening for the last two days, make yourself useful and inform the public here why the errors and disappearance of the numbered and lettered lists below is occurring without fail in this software, every time. I must be donig something wrong with regards to the latest rules of using this software. Please then, if you have knowledge of it, tell the forum what that is. You might be helping someone who reads this.

Otherwise, what - other than abuse - is your purpose in replying to this request for help?
Please don’t feel it necessary to answer that question. Of course. It’s rhetorical.

Final point: People who use software are all aware that updates in operating systems and in most programs are mandatory; or they eventually become mandatory as the changes in the software environment render older or previous versions obsolete or non-functioning, or error-prone. So it is not a free choice whether or not to update. A minimum of critical thinking reveals that. What works from December to January to February suddenly does not work anymore in March.What then?

Please see how much bullshit you wrote in your “question”, and how much important information you omitted, while uselessly expressing your emotions.

You started claiming that something is impossible (not “I can’t”, just “Impossible”).
You followed with the “If only LibreOffice writer worked as simply and easily” complaint, which didn’t provide anyone anything useful.
Then you wrote that Writer “automatically resisted at every step”, without explaining what was those specific steps, and what was the resistance exactly.
Then the “automatically alters your list and destroys the numbering” again doesn’t provide any specifics.
And then you end with “LibreOffice does not allow it. Don’t know why.”, which is, again, not a question, just some kind of a blame.

And then, in the comments, it appears that the problem appeared lately, and before, it worked (and that crucial information should had been there in the question, instead of that useless stuff); but you still didn’t mention what changed on your system (OS upgrade? LibreOffice upgrade? Change of other software? …). Then you answer my question providing the LibreOffice version details, and I see your operating system - but no file format still.

My initial comment was IMO very important. I (and others even more) spend much time helping people - for free, just because we can. But those people - you specifically among them - just don’t care a little bit to be helpful to those poor lads that try to help you. You don’t read the how to; you don’t try to control your emptions. And I just hope that my pushback could allow you to realize that not every “question” is a good question.

And no, I don’t know what happened to you - you still haven’t provided relevant information.

You must be absolutely correct. **Your comment above is very important as you say, because the incapacity of the program to save numbered and lettered lists (I noted, an exercise/ testing/ working through materials format, frequently deployed by teachers), or their automated disappearance upon reopening the file, or the reversion (“autocorrection”?) of desired format to an empty line or other automated format (“resistance” to desired formatting) is clearly synonymous with “how dare you create such a nonsense suite”. Anyone can see, as you have, that these phrases have the same exact meaning, as you explained.

Nothing in the operating system has been changed; I suppose if it had I might have mentioned it. Negative statements in explanation are not commonly required. (“The power in my district did not shut down in a blackout today.” “The Internet service in my area is poor, but it is functioning at the moment.”) It doesn’t occur to most of us to include such statements in noting that something ordinary cannot be done in a LibreOffice suite program. That is how issues like this often occur; they surprise us when they appear mysteriously and users ask for help only because they appear. If we knew what was wrong, we would not be here wasting everyone’s time asking.

The software really needs a method to make and save lists of this kind. As I’ve explained now the next day after a night of unsuccessful attempts to create a simple document, I’m quite desperate for this having lost two days to software failure or incorrect use or corruption, or whateve the cause turns out to be. Currently 45 students in two different college sections are anxiously writing to me that the files they received do not reflect the usual format, and it is causing them enormous difficulty and frustration. This in turn adds pressure on the user to stay up and mess with the software hoping to find the way back. When students receive the files, they convert them themselves to Word or Google Docs files, because those are by default “universal” formats available to non-specialists and in use throughout university and general education systems, globally.
Now if you would, please allow the responses to come from folks who recognize the issue and want to help, and please, please do not participate in this question any further.

1 Like

Diagnostic measures

The only way I can recreate an issue similar to what is described, is if I save the file to the DocBook xml format. With this format, the error is consistent.

Saving as plaintext, ODF, Unified Office format and every Microsoft format available (including rtf and Word-xml) the zero-content ordered list is preserved when I reopen in Writer or Word.

Best practice

The only way to ensure that document content and structure is preserved, is by saving to Writer’s native format, i.e. as an “odt file”. This may be what you are doing. I cannot see any clear statement either way about this, so I thought it pertinent to mention.

To proceed

If your issue is not solved, nor explained, please upload that “skeleton” file of yours. Even though it may seem useless to you, some of us may find clues in that file to solve the mystery. We have seen the pictures, and do not doubt your description, but we have seen many cases where not everything is as it appears. The upload tool is the one with an upwards pointing arrow, near the middle of the editor toolbar when you type/edit a comment. If possible, also upload a file which have passed through the service where you submit to your students (upload and download back again from there first), for comparison.

2 Likes

On the contrary, it is very easy to do this in Writer. But you must first understand what a list style is (it would have much better been designated as “numbering style”).

In Writer, every numbering is multi-level (chapter numbering is just another kind of numbering). Therefore, every time you create a numbered list, you can have items attached to different levels of this single list, e.g. your 1. 2. 3. … items are at level 1 and your a. b. c. … are at level 2. The fact that they both belong to the same list results in automatic reset of level-2 numbers when you change level-1.

Getting the desired numbering scheme is only a matter of configuring the list style. I guess that you number your lists with the toolbar button or F12 which uses the courtesy (Word-) compatibility mode. You can configure it with Format>Bullets & Numbering, Customize tab. Choose Number: kind for each level. Indentation is set in the Position tab.

To enter an item at level 2, press Tab at its very beginning.

A word of warning: using the F12 or toolbar button numbering mode is akin to direct formatting which complicates document maintenace. In addition, this kind of direct formatting is not very consistent: it covers all “manual” lists which means the configuration has only a limited extent so that it can be changed for any list. The consequence is you can’t change the numbering at once from a single location for all your lists.

A better option is to design your own list style or to customise an existing one so that this list style is reserved for this type of list exclusively, the other list numbering being formatted by other list styles. List style are accessed from the style sidepane (F11) through the fifth icon from the left.

Then either you assign this style with a double click when the cursor is in the list or, better, you associate it with a paragraph style, like Numbering 1 in its Outline & List tab. You then only need to assign this paragraph style to an item to get it formatted according to the paragraph style and simultaneously get it numbered.

3 Likes

Thank you for the thorough explanation of how to set up the options. I will try this when time allows.
If I may, this is what I did and what happened (repeated over and over, over a four hour period, becoming very frustrating by the time the failure occurred again each time. Here are screen shots before/ and after/ saving the file. (Incidentally, I tried this on several possible plain, default templates to make sure that I was not using a corrupted template, if that’s possible.)


I hope this clarifies what is happening a bit.
The “before” screenshot shows the appearance of the lists as I made them. I carefully saved the document several times, in several locations to ensure I wouldn’t lose the work.

Next is an “after” screenshot:
after_LibreOffice Writer
The “before” version was used to export/ print to a PDF also. Then I uploaded the document to an education program our college uses and closed the LibreOffice Writer application.
Next I downloaded the document back from that server to make certain that the students would receive the document with no issues. It appeared the way it does in the “after” screenshot. (There are multiple pages; this is just one that is characteristic of the problem occurring.)

You can see there that the numbering and lettered options are removed each time. Same occurred with saved copies of the original, and I don’t know why!

I made the lists using the toolbar just above the text area, choosing the numbering list and a spacebar space as a placeholder for each line, or selecting the lettered lists, indenting them to where I wanted them more or less, then touching the “restart numbering” button (also in the toolbar). Then proceeded to create as many lettered blanks as needed for each exercise, by touching the space bar once, then “enter”, resulting in the lettered lists, (a, b, c, d, etc.).

Having saved this and a pdf copy for students are able to use one or the other format on their computers, and uploaded them, this strange disappearance of the saved elements occured.

If you have a clue as to why this repeated failure occurred, please help! Very mysterious.

You didn’t say you had blank numbered lines. You need to untick the box in Tools - AutoCorrect - AutoCorrect options that removes blank numbered lines in lists. Either that, or enter a space at the start of each line.

I’ll post the trail to the exact box when I’m at a computer

1 Like

I hear you, but like I said in the reply post, I entered a space at the start of each line when I created the file. This happened anyway!

1 Like

Thank you EarnestAl, my settings in Writer are exactly the same as those in your screenshot. So indeed, I thought I had the setup right; I’ve tried a repair install just in case the issue might be eliminated that way, but so far, the files remain full of blank lines where I had numbers and/or letters. And btw, just emphasis, I created the lines with the lettered options by touching the space bar and Enter until I had the right number of lines before switching back to the numbers, all via the toolbar.

I appreciate your help very much. I haven’t discovered what the issue is yet however. If it gets solved, I will certainly let you know in order not to take more of your time.

Argh. Frustrated.

Just created four or six more versions of the file from scratch.
Every one of them, the numbered and lettered lines under the “exercise #” were present at save; and when reopened, all disappeared.

Utter failure. Please there has to be a way to force this to work.

Which file format do you use?

And which version of LibreOffice?

Version: 7.2.5.2 (x64) / LibreOffice Community
Build ID: 499f9727c189e6ef3471021d6132d4c694f357e5
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

Please answer the “Which file format do you use?” part. Then, you wrote that you uploaded the document to your college system, and downloaded it back. The question is: are the files that you uploaded and downloaded same? Maybe your college system alters it (e.g., converts to some specific format). Can you compare the file types and sizes before and after? Does the problem happen with the original file before the upload?

Again, this is a negative question that one doesn’t intuitively think necessary to state unless something is known to have occurred. They are the same. The files have to be closed in order to upload them, so if the format is eliminated when the file is closed prior to uploading, I have no way of knowing until I reopen the file, or open one of the uploaded files, or both.
When saved, the format is correct.
When closed and uploaded, the file that comes back in the download no longer has any numbered or letterd lists. They are eliminated. Same when the files on my hard drive are reopened.
The lists are “saved” only as long as the file is open on my desktop.

Try unticking the AutoCorrect setting Delete spaces and tabs at the beginning and end of paragraph

[Edit] Ignore the paragraph above. The paragraphs must still be there as they take up vertical space in your screenshot but I cannot see the formatting marks.

1 Like