Numbering paragraphs hierarchy problem

Which platform, LO version, and file format are you using?

could you possibly

  • explain step by step what you did
  • paste screenshots in s Draw file and make assessible here
  • provide a sample file ( be careful about the content this is a public site)?

Does it help to right-click on the problem headings and select Continue previous numbering?

1ST EDIT: It may help if you would answer our initial calls for further detail (refer the comments against your question). You also mention and interchange the terms “heading” and “paragraph” in such a way that it is difficult to fully understand exactly what you are doing. Are you trying to obtain numbering against each Heading N style or against the Default Style or Text Body or some other style (perhaps a custom heading or text style)?

My original answer was partly a suggestion as there are essentially two different methods of applying numbering and each will have different results depending on context:

  • Creating a nested list (refer Writer Guide v3.6 pp.78-81, 186-187, 215, 230-235).
  • Numbering a hierarchy of headings (pp.197-202).

There are other aspects to applying numbering (e.g., conditional paragraph styles, captions, table of contents, and bibliography) but all relate back to these two methods / requirements. If at any point you have use the Creating a nested list option (e.g., styles) to set numbering for headings then you will obtain the context menu I indicated and as shown here. This is a common cause of outline numbering not renumbering as expected i.e., because a list XML coding is being used in addition to the usual heading / paragraph pairing. The fact that this context menu does not display is indicative that you have not used this approach (at least for the heading in question).

This may mean your problem is more serious (unlikely) or it may just be an artefact of using this numbering against a style that has not been defined correctly (likely). As per the suggestion by @mahfiaz I would try clearing the formatting on the entries in question (including any list settings) and re-apply the required style.

2ND EDIT: As a result of examining the source file provided in this post, it is clearer what the problem is and how to fix it. The basis of the problem is that currently the XML code for your headings looks list this (a nested list as I mentioned) and this is interfering with getting it to look like this (a standard outline heading). I recommend using the provided Heading N styles rather than your custom titreN styles. It is likely that some of the settings on the titreN styles have been modified to the point where they now have problematic definitions. You will need to go through your document and for each heading:

  • Clear the formatting (Apply Style pull down menu > Clear formatting).
  • If after clearing the formatting a leading number is still present, click the Numbering On/Off toolbar button or press F12.
  • Apply the corresponding heading style e.g., for titre1 apply Heading 1, for titre2 apply Heading 2 etc.

Once you have done this for all headings you then need to:

  • Configure outline numbering (Tools > Outline Numbering…) by changing titre1 to Heading 1 for level 1 etc.
  • Click OK.

Your headings should renumber correctly. You can now style each Heading N style as you wish to make them match the original titre entries, just avoid changing the Outline & Numbering tab details.

I do not have that option ??? LO4 only up or down one level

I do not see this option on LO4?

Instead go to the heading, make it use some normal text format (Default or Text would do just fine) and change it back to heading. Boom and normal numbering is back.

Thanks for complete answer I will take time to look at all features, indeed I did not know the difference between numbering and outline numbering. Also I cannot change back to heading style because autoupdate feature is disabled, cannot set it back on and I need to change the police character (and the doc is quite large) so have to work the problem with doc as it is thanks loads both of you it made things very clear now in all cases will let you know

Started from a plain ascii text and started adding headings. Going back to normal text format doesn’t work. Restart numbering leads to all the heading x in the document getting the same number. Continue previous not available. Tried tons of things. Nothing works. Forest of bugs. This is supposed to be a word processor… Costs more time than it saves.

So you use Tools → Outline, select 1-10 from the left, choose numbering type to be 1, 2, 3, … and use heading styles (Heading 1, Heading 2) and it still doesn’t work?

Thank you for answers
Yes, this is exactly my problem, I do exactly what you say, and for some reason level 2 and 3 do not take in account the changes of paragraphs in level 1 and it stays numbering from the first paragraph continuous, it goes 1.1; 1.1.1; 1.2; 1.2.1; 1.3;1.3.1; 2; 1.4; 1.4.1 etc…instead of 1; 1.1; 1.1.1; 1.2; 1.2.1; 1.3;1.3.1;2;2.4; 2.4.1 etc…;;


@natacha - If @oweng’s advice doesn’t solve the problem I would like to address something I saw in your answer

…instead of 1; 1.1; 1.1.1; 1.2; 1.2.1; 1.3;1.3.1;2;2.4; 2.4.1 etc…;;

from 1 to 2 all is correct or could be correct
however after 2 is a jump
2; 2.4 is this the problem point?
If so @oweng’s advice can very likely be the solution.

indeed this seems the problem exept I do not have previous numbering as an option in LO4

@natacha - I just tried to simulate your problem on 3.6. and 4.0.2 and could not create the error.
Are you sure you followed all advices by @oweng and @mahfiaz? Step by step with checkmarks on a paper note?

If YES, than:
Is it possible for you to attach the file so we can have a look at it?

Before you could make the following check: Create a dark background to see if there is a white font used for headings between 2 and 2.4

Do you have a TOC? If so, what is the numbering you see in the TOC? Create a TOC could be a good possibility for a check as well.

Please inform also on OS (1st question by @oweng)

thanks all for following up

yes I have a TOC and same problem occurs there tried w/background also and don’t see anything

I am using Ubuntu 12.4

file is very big try to attach it anyhow

problem occurs between pages 90 and 98


here is the attachmentdoc_test.odt

As you mentioned, the file is probably too big for attaching. I get an error trying to download the attachment. In any case, thanks for letting us know which OS you are using.


I have suppressed a large part of the content to send a lighter file, the problem keeps on happening after the second part (level 1) that is now between page 38 and page 46

i mean numbering goes
1; 1.1; 1.1.1; 1.1.2; 1.1.3; 2; 1.1.4???

(i previously had more subparts but same problem)

here is shotrtened file attacheddoc_test.odt

Thanks natacha for providing an example. Your custom styles (titre1, titre2, etc.) appear to be the problem. At some point it appears you have used the toolbar Numbering On/Off button on some headings as well as employed a nested list against the headings. This is interfering with the outline numbering. I will edit my answer to explain how to fix your document.

@natacha - I also had a look at your attached file and advice to follow @oweng’s recommendations. However, I recommend to read the manual concerning the difference between “Numbering” (a bullet list but with numbers) and Outline Numbering. Additionally I suggest to read styles in general. IMHO the styles in LibO are great and allows very efficient and simple formatting of a document; but you need to read… Have fun!