Object is nonfunctional

Libra 6 and 7

I get an “object is nonfunctional” on any file (Writer) opened. New files and previous files are both affected. Tried uninstalling/reinstalling. Started two days ago.

Operating system? Complete version numbers please, like, four digits. The only reference that Google offered is https://bugs.documentfoundation.org/show_bug.cgi?id=133495, but there you get a crash after clicking in a scrollbar.

Tried uninstalling/reinstalling.

Please note If a problem is caused by a corrupt user profile, reinstalling LibreOffice won’t help at all, since this won’t touch the user profile. Therefore: Before reinstalling always check whether the user profile might be the cause of a problem.

To test whether LibreOffice user profile is causing the issue:

  • Start LibreOffice
  • Restart in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Click button Continue in Safe Mode
  • Perform the procedure showing the problem and check whether the problem is gone (If you need to open a file, use File → Open and do not use some other procedure)

Sorry about the lack of info: Here are the specifics.

Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 8; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Did you act on @anon73440385’s suggestion already?

I followed Opaque’s recommendation and it did seem to be working but has reverted to the crashing state.

The emphasis on my comment was on “test whether LibreOffice user profile is causing the issue”. No feedback on test result, results in no probable solution - see my answer below.

Captured a crash report:

Process: soffice [96592]
Path: /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier: org.libreoffice.script
Version: (
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: soffice [96592]
User ID: 501

Date/Time: 2021-01-31 10:47:21.359 -0800
OS Version: Mac OS X 10.15.7 (19H114)
Report Version: 12
Anonymous UUID: C2BC50A7-C91A-DCCD-E043-CEADDE5E69BB

Time Awake Since Boot: 340000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000020

VM Regions Near 0x20:

__TEXT 0000000109003000-0000000109004000 [ 4K] r-x/r-x SM=COW /Applications/LibreOffice.app/Cont


according to your comment “…recommendation and it did seem to be working” the solution should be:

Reset your user profile by performing:

  • Start LibreOffice
  • Start in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Archive your profile expanding Advanced (click on the word Advanced right above Help button) and click Archive User Profile button
  • Select option Reset to factory settings
  • Activate [x] Reset entire user profile
  • Click button Apply Changes and Restart

Hope that fixes your issue permanently.

Okay, did the above. So far, so good. I will update after using a few more files. Thank you!!!

Still looking good. Thank you for your assistance!