.odb with macros made on 64bit wont open in 32bit ...?

I have a problem opening an .odb made in 64bit machine when the file is copied to a 32bit machine(or 32 bitLO on 64bit machine) …

I checked java (+macro security ect) on each install of 32 vs 64 bit LO (where relevant);
-win7(64) PC,
-win10(64) PC,
-win8(32bit on 32efi)
-win10(‘64bit’ on 32bit efi),
-Mageia(32bit on 32bit efi)

…first issues with connection to data source (probably wrong java) but having double checked java and opening the .odb file I still get a:

“…string truncation right…gds_$send_failed…expected length 20, actual 21 …exiting…caused by isc_service_query”

each time in 32bitLO when tables/queries are selected in main menu … an error which is not present in 64bitLO on same machine (ie where machine can run either version and java is swapped)…

a fresh database (1table, no macros,no triggers, no data) works as expected when opened in 32bit and 64bit LO … I presume some problem with macros between versions…???

I will try to get some more details to troubleshoot, but any suggestions from the hive would be most welcome !

PS: all using Firebird embeded, tried with LO7.1 and LO7.2…(.odb originates from LO6.x) - java8(32 and 64bit) on windows, java11(i think) on fresh Mageia install

PPS: why 32bit anyway??? … using old mini-pcs (Linx7) as hand held data loggers > they come with a 32bit locked bios (great work MS:/) and 1 GB ram - win10 does not care, but other 64 bit winOS wont install, but will run from external live media (cpu is 64bit capable…) - for a Linux install need a modified bootia.efi, which is already included in Mageia … (Puppy Linux (live) runs really great on Linx7, but cant install due to MS 32bit uefi bios … sigh)

      • so why not just stick to win10 since 64bitLO runs fine?- because win10 is so horribly bloated that 1gb ram and i/o on 20gb hdd gets pretty much maxed out…+ i am so f@@kin’ sick of killing cortana and all the other backragound crap that was never fixed by MS…

Upload some dummy document which is able to demonstrate the issue. I don’t don’t run 32-bit machines anymore but someone else should be able to reproduce and analyse the issue.

Tried to repost as comment, but “ok” Button can’t be pressed on my mobile. Cute design … I’m really impressed of discourse.

I remember a bug concerning length of fields not enforced by older versions of the database.

So: Do you use HSQL or firebird? All Versions of LO are the same? Could you find out the Version? With wich Version was the Database created?

Edit: One if the changed bugs in Firebird:

(also edit above) … using firebird - 32bit 7.1 and 7.2 tried - .odb originally from 64bit LO6.x, but works fine (+ modified recently) in 64bit LO7.1/7.2 … will try to create some more info (thanks guys!)

Here is a bug report concerning non accessible tables in 7.2, because limits were not enforced properly in older firebird releases.

thanks that is very useful link, this seems the same issue (so maybe not 32/64 bit related at all)…for now reverting to LO7.1 [64bit] is a fix :confused: on win7 pc… but still cant track down the offending table…is it actually a user data issue?, seems odd that i also got the same ‘20 vs 21 truncation message’ as the original bug report posted by a different user…maybe an internal system table perhapse?