ODBC connection fails in Writer

We had a mail merge system running for several years on Libre Office 4.*(32bit), on a 64bit platform,with 32bit sqliteodbc driver, and a sqlite3 database on a separate box, accessed as peer-to-peer network. All Windows, v8 on the production platform and now W10 on a test/rebuild platform. The system was my build.

The system collapsed when, after four years, we upgraded to LibreOffice v6.*. I’ve implemented the upgrade in 32bit and in 64bit with about the same result each time. (irrelevant errors excluded where obviously incorrect configurations were used during systematic testing [e.g. sqlite driver w/ sqlite3 database, and 32bit datasource with 64bit Libre])

The error is that the address book can be set up in Libre Office, correctly loading the myDatabase.sqlite data into a C://etc/etc/addresses.odb database, and presenting the data row by row when printed with assigned fields. Close the file and reopen it, it still works. Each document prints with the next row of data. All the data is presented in a dialogue during the printing dialogue process.

Yet, if we close LibreOffice and restart, then the addresses.odb database is still connected to the fields, but it does not contain the myDatabse.sqlite data. Likewise, if I go to the addresses.odb file and open it with LibreOffice, it is empty.

The 32-bit ODBC Data Source Adminsitrator (*Run as Administrator in WIndows 10) shows the System DSN Data Source (*e.g. myDataSource), but the addresses.odb database I connected to the data source does not appear to remain connected after restart.

This question is similar to one asked and not directly resolved here:

The answer there suggested some might be surprised that Libre version, bit-length, platform and OS can make a difference. No surprises there for me - I anticipated conflicts from a multiple-version upgrade – but after controlling for variations – e.g. matching 32-bit libre v6.* with 32-bit sqliteodbc on 64 bit Win10 platform accessing SQLite3 database - I’m perplexed that after resolving platform/bit-length issues, the formerly stable system cannot maintain a connection.

Can anyone offer suggestions?

Update: I eventually rolled back to a 4.* version of Libre. System seems able to maintain connections with remote SQLite database.

At this point, having unsuccessfully tried to set up SQLiteODBC connections in Libre 6.* (32 or 64bit) then immediately getting results in 4.* I have a nagging suspicion I’m relying on Libre functionality that somehow has not been maintained in recent versions.

Please edit in your question to add your update.