ODC file extension won't open

Hi - using LO on Win 7 in English.
I had opened a calc doc and inserted some charts which had been edited. These were then copied and pasted into a writer doc ready to be exported as pdf for a college project. I then saved the document and it was given an .ODC extension. I didn’t think anything of this as this is the first time I have tried this.
I closed LO and later went to reopen the document but it will not open. I can see the document in its correct layout with my charts in the thumbnails that pop up when you open LO but regardless of everything I have tried (opening it with any pkg in LO writer, calc etc) the document will not open.

The document is not data sensitive so I have attached it. If anyone can open it I would be very very grateful. I have also attached screenshot of what it should look like.

Can’t upload files because I need points or something so sorry can’t give you anything to work with but any input to solving my problem gratefully received.

Thanks - Ben.

Have you tried (in Windows Explorer) just changing the file extension?

Yep - but can’t change the file extension. Have given up and redone the work. Fault seems to be created when you drag and drop a chart from calc into a writer doc. Works when you export it though. Will check extensions from now on though to make sure docs are saved in something usable.

Hi - From what I was able to test in previous versions, save to .odc was possible when saving from the "edit"mode of a chart. May be you can try to open when in same context?

It seems that this feature is not yet integrated due to its instability: tdf#65175


Hi - I just tried on Windows 7/64 & Version:
Build ID: b5ac74bf8683a92078a2bc8aff97d4b436af63cb
Locale: fr_FR

This version allows me to save (same procedure as that I gave in my previous answer) and re-open an ODC chart with File > Open

It is also possible to insert it in a spreadsheet: Insert > Object > Chart From File

I will try that - I just saved it as the default extension assuming it would be .odt I will open another doc and select all then edit then try to open doc - will leave feed back - any more suggestions welcomed.
Nope - I am still unable to open this document - more suggestions please. Just to be clear - it was created in LO and saved with an automatic extension (.ODC) - how do I now open that file or change the extension? If I can’t open the document - how do I get to ‘edit’ mode?

My idea was to create (or open) another document containing a chart, double-click in the chart, and then try to File> Open your .odc. Indeed, it is in this context (editing chart) that save to .odc is possible…

No luck - Ctrl+O does not function and the ‘open’ is greyed out in the drop down list.

Don’t seem to be able to reopen the file and have tried everything. I believe that Pierre’s answer was the most appropriate - “It seems that this feature is not yet integrated due to its instability: tdf#65175” - if this is a bug and it is known to be an issue how is the file able to be saved in this default format that can’t then be re-opened?

If anybody else has this issue - I ended up re doing the work. If I had done that to start off with it would have saved a heap of anx’t and frustration and been quicker than trying to solve the problem.

I got the same problem… odc document created by calc, last open was 12.5.2015 i try to open it today, but i cannot… it opens just a chart