Odd behaviour when I first run a macro my buttons briefly appear

I use Calc,, to transcribe old weather data which is saved in an XML file. At the end of the day, I save my spreadsheet, ready for use the next day. Cell C5 is positioned at the top left of the screen. I open the spreadsheet, and start entering data. I have a macro, CopyDown, which is activated with a hotkey Alt-]. The first time the macro is run, I see the buttons, which are out of sight at the top left corner of the spreadsheet, in cells A1:A3, briefly appear.

I have links to a four second video to show what happens, and a copy of my spreadsheet.

I’m using an updated Windows 10 with a generic video card.

What name of the macro is executed.
Keyboard shortcuts are not loaded with the file.

And I really don’t understand what your question is. please clarify

Qual nome da macro é executada.
Atalhos de teclado não são carregados com o arquivo.

E realmenet não entendi qual sua dúvida. favor esclarecer

Hello Gilberto,

Further to my email yesterday. Today I got the same behaviour with my first CopyDown macro. Then, out of curiosity, I checked on the Setup sheet. Those buttons were fine. I went back to the Log Page sheet with Alt-J, entered the last values in a column and did an UpAndOver, Alt-UpArrow, to get to the top of the next column. When I did that, I got the same flash of buttons. It was interesting, because the CopyDown macro was not involved.

Take care,


Hello Gilberto,

One last update. On a computer downstairs, I have an old version of LibreCalc running. I put my Omaha and Kearsarge spreadsheets on that PC. I had none of the problems with that version of Calc. No white lines, no flash of buttons, and I could replace the cloudy buttons on the Kearsarge spreadsheet and they remained orange after several cycles of open, save, close and re-open.

Next, I updated LibreOffice to 7.6.3. When I reran the spreadsheets, I got the flash of the buttons with a CopyDown, and the buttons on Kearsarge went cloudy after opening, saving and re-opening the spreadsheet. There were no white lines. However, it sometimes takes a while for them to appear. I closed the spreadsheets, shut down the PC and came upstairs.

Then, I thought maybe I needed to load a new image. I went back down, started the PC, loaded the spreadsheets, got the next image and tried again. I couldn’t get the buttons to flash, and there were no white lines. The Kearsarge buttons on the Setup sheet, which were saved as Orange, were cloudy when I opened that spreadsheet. I deleted them, replaced them with orange buttons, saved the spreadsheet. The buttons were cloudy when I re-opened it.

It is very strange, to say the least.

This is the old version I had downstairs;

Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new;
Locale: en-CA (en_CA); Calc: group

Device name BasementTV
Processor AMD Athlon™ 5150 APU with Radeon™ R3 1.60 GHz
Installed RAM 4.00 GB (3.43 GB usable)
Device ID C7AE16A4-5E60-4AF6-A062-1EC5F426FE66
Product ID 00326-10000-00000-AA233
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

One way to speed up macro processing is to turn off screen refresh.

Use this command at the beginning of the macro:
ThisComponent.CurrentController.Frame.ComponentWindow.Visible = “False”
And this one, at the end of the macro.
ThisComponent.CurrentController.Frame.ComponentWindow.Visible = “True”
During the Macro execution process, the screen remains gray.

This procedure eliminates screen flickering.

Uma maneira de agilizar o processamento de macros, é desligando a atualização de tela.

Use este comando no inicio da macro:
ThisComponent.CurrentController.Frame.ComponentWindow.Visible = “False”

E este, no final da macro.
ThisComponent.CurrentController.Frame.ComponentWindow.Visible = “True”

Durante o processo de execução da Macro, a tela permanece cinza.

Este procedimento elimina o piscar de tela.

Thank you, Gilberto, but the cure was worse than the disease. I’ll have to leave things as they are.

Take care,