Odd Problem with LanguageTool

First off, sorry if this is the wrong place to post this. I’m still very new to LibreOffice. If there’s a better place, please let me know.

Anyway, I’ve been having the bizarre problem with LanguageTool where it won’t let me simply ignore once when checking grammar. Whenever I click “Ignore Once,” it does nothing. To proceed, I either have to correct the grammar mistake or press “Ignore Rule.” It’s really annoying since I might allow the passive voice once, but then because I have to click “Ignore Rule” to continue, it assumes that I don’t care about the passive voice at all.

If anybody has any suggestions, please let me know.


P.S. For anybody with a similar problem, I’ve found that fiddling with the settings (especially disabling and re-enabling LanguageTool) can sometimes solve the problem for a while.


Can you tell us the LibreOffice version you are usign and operating system. Thanks.

Of course! The version is 6.3.6 and the OS is Windows 10.

Likely related to tdf#132922

… LanguageTool … when spell-checking.

LanguageTool as a LibreOffice extension does not check spelling, only grammar/style.

Ah, you’re completely right! When I wrote “spell-check,” I really meant “grammar check.” I’m just used to calling any editing software “spell-check.” I’ll edit the post to reflect this.