ODG drawing covered in black shapes

Tried opening a .odg file in Draw and had black shapes covering the artwork. It looks fine in the “recent files” preview and print preview but in the editing window everything of interest is covered in black blobs.

Tried in 6.2 and 6.3 on Win10 64-bit. Tried saving as ODF and re-opening, same problem. Tried toggling OpenGL, hardware exceleration off.

Only workaround so far was importing the PDF version and editing that.

Is this a bug in .odg import or is there some workaround that I am not finding?

Have you tried to restart LibreOffice in Safe Mode (Help -> Restart in Safe Mode -> Button: Continue in Safe Mode and opening your .odg file?
If that works, most probable your user profile is corrupt and you need to reset to factory settings (Close LibreOffice from safe mode, start again and use Help -> Restart in Safe Mode once more but choose option Reset to factory settings and button Apply Changes and Restart (after having performed Advanced -> Button: Archive User Profile

Tried safe mode, and installing the newest version. No joy.

OK - could you upload or does it contain confidential data / sensitive personal information ?

Confidential technical drawings unfortunately. I can make due with the kluge of importing the PDF version for the archived documents. Still it looks like others may be hitting a similar issue with pictures replaced by black boxes.

Can you select those blobs?

Is the shape regular? Are all equally shaped?

Have other people (using other computers) edited the drawings?
Perhaps inserted objects, needing a servicing application which is not installed on your computer.

Is “real” printout also unmarked by the blobs?
Print to paper has a higher resolution than screen preview, so you may see stuff there which isn’t apparent in the preview.

Confidential technical drawings

Makes me ask, whether it has been created with another application and imported to Draw?