ODP Drawing Toolbar


I start Libre Impress and the drawing toolbar is rendered. I did not have my drawing toolbar rendered when closing out of Libre Impress. I get the same result when starting a blank ODP.

Why does Libre Impress insist on rendering the drawing toolbar?


In the Standard User Interface, if I unhighlight Drawing in View > Toolbars it is not visible on re-opening. Version: (x64), OS: Windows 10.0 Build 19042

What User Interface are you using? Check with View > User Interface as I think one of the single interfaces resets to default each time.

Does LO close cleanly? If not it might not save settings.

1 Like

Please test the items that are applicable to you:
First steps

For further assistance, please share your operating system and LibreOffice version. Thank you.

stephen@LENOVO-SSD ~/Desktop $ uname -a
Linux LENOVO-SSD 5.11.0-40-generic #44~20.04.2-Ubuntu SMP Tue Oct 26 18:07:44 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
stephen@LENOVO-SSD ~/Desktop $ cat /etc/linuxmint/info
DESCRIPTION=“Linux Mint 20.2 Uma”
GRUB_TITLE=Linux Mint 20.2 Cinnamon
stephen@LENOVO-SSD ~/Desktop $ /usr/bin/soffice --version
LibreOffice 40(Build:2)

stephen@LENOVO-SSD ~/Desktop $


I am running the Standard Toolbar as listed under /MENU/View/User Interface

LO seems to close cleanly, as I have not noticed any problems exiting out of any of the LO members.

What is the expected behavior of Libre Impress when opening a blank ODP file? Should the drawing toolbar be seen or not when it is not rendered beforehand?

It depends on whether it is set to be visible

In a virgin installation, the drawing toolbar is visible. That is really the only default.

I read that when Ubuntu 20 came out the Canonical version of LO had a variety of different, apparently unrelated issues that had to be fixed by purging the installation and reinstalling. I think that the problem has been resolved since then.

Thanks for taking the time to reply.

A friend of mine with LO 7.2 has the same result as you.

I am of the position now the version of my distro and it only be able to support LO 6.4 is my problem. So, unless the LO developers wish to fix the problem in LO 6.4 I am stuck with this problem.


Possibly, resetting your User profile will fix the issue. It will change all your altered settings back to factory settings though. You should save a copy of the user folder so you can copy back your templates, user dictionary, etc. (but not config).

The nuclear option:

  • I no longer have a Linux installation due to machine failure. I kept a note of this question for future reference in case the issue arose on next pc: Export or print to PDF - no text. Purging LO will remove your User profile. If you have created any of your own colour palettes (.soc) you should save a copy elsewhere too

I will have to live with this problem until the LO developers repair LO 6.x

With LibreOffice closed, the easiest way would be to rename your LO user folder to userold. Start LibreOffice, in View - Toolbars unhighlight Drawing. Close LibreOffice and reopen to see if toolbar reappears.
If problem is fixed then closer LO and copy over folders such as templates, AutoCorrect and workbook from userold to the newly created user folder, overwriting the new folders. Don’t copy configure.