Ods-file chrashes LO 3.5 instantly but opens OK in OO

I’ve got a spreadsheet (ods-file) that crashes libre office calc (or more precisely, all open libre office programs are closed) instantly when I try to open it. The same ods-file, opens without any trouble in Open Office calc.

Restoring the file also crashes libre office.

Also, I was able to open the spreadsheet in an earlier version of LibreOffice. (Not sure exactly what version I used before I upgraded to 3.5)

If anyone wants to have a look at the spreadsheet, I think I would be able to remove/replace sensitive data and send the file.

I have tried to open this file and on my computer LibreOffice v3.5.1 on Windows XP it opens up successfully. Yes it opens up some minutes in the middle of opening I get LibreOffice not responding, but if waiting for some minutes it opens up successfully without a problem.

Maybe your profile is corrupted. For test I suggest to close LibreOffice, rename a profile “user” directory to something like “user_backup”, start LibreOffice and open attached file. After test just rename back profile to original name.

See more about profile:

Please do Edit your post and add an external link (attachments don’t work in this platform). Otherwise it is impossible to provide any feedback :wink:

There seems to be no problem attaching a file… (if you have enough karma that is…)

Please report a bug at https://www.libreoffice.org/get-help/bug/ and attach your file there.

Sorry for the late response.

Anyway, a spreadsheet template which causes the crash can be downloaded from http://dl.dropbox.com/u/297044/mal.ots

Files based on this template also makes LO crash. I’m running version

BTW, I was not able to get the attach feature to work, I tried Opera, Firefox and IE…

Kind regards

No crash here, same version. Did you report the bug?

I tried, but I got interrupted in the process. However, the problem seems to be solved after recreating the profile.

Thanks to L-user for suggesting renaming the profile user. I did, and a new profile was created, and the file now opens OK!