Odt file filled with strange characters, zip repair doesn't work

Today I opened my 35KB odt file but it is corrupted :frowning: I last worked in it about a month ago with Libreoffice 6
It’s now filled with weird characters depending on the LibreOffice version. With the latest version I just updated, I get 7 pages of mostly Chinese looking characters. With older versions (such as 6 or I get about 150 pages with a couple lines of strange characters on each.
The problem occurs only in this document.
woonst.odt (34.4 KB)

I tried repairing with WinRAR and 7-zip, as well as many tools online. Errors I get are “archive unknown format”, “is not archive”, found 0 files, etc.

Can someone recover any text from my file? Really sad that a file can get corrupted so badly (unrepairable) and you don’t have a backup of the plain text or previous save…

Really sad that a file can get corrupted so badly (unrepairable) and you don’t have a backup of the plain text or previous save…

Who is you?

It is completely destroyed on disk. Check if your storage is failing. And you have it lost completely, unless you manage to find a backup (I do not believe that you could get some ‘undelete’-like utility to recover something as old as 30+ days ago, if you use your system often), especially on a failing media.

Yet it still says 35 kB filesize?

Your OS is Windows?

Yes it still says 35 kB filesize, what is strange here? It only would change if the file metadata was broken on your filesystem, which is typically located in a different place on the media than the file data itself.

Yes I’m running Windows best version (a.k.a win 7).

But I also uploaded the file and it still says (34.4 KB).
“Completely destroyed” – do you mean an ungodly number of bits are flipped? Because the file is certainly not empty (can also see it when opened in notepad).

What is your expectation?
There is a record on your file allocation table (or its analog in your used filesystem), telling “there is a file woonst.odt starting from position X through position Y on the media”; position X through position Y taking 35 kB. There are the bytes on that area, that got changed completely (and likely, some surrounding bytes got changed, too) because of … well, unknown; I guessed some HW problem, but could be anything. And that means that you still can read the bytes, and send them anywhere - all those now-useless bytes from X to Y.

You can search in the temporary directory (although there is little hope).
Open the attached file and click the “Find Deleted Files” button. If there is a file with a suitable size in the list of files, then rename its extension from .tmp to .odt and try to open it in LO.
FindDeletedFiles.ods (12.5 KB)


Makes sense!
The file was stored on an external drive. Didn’t know such a bad corruption was likely to take place. I certainly learned my lesson; from now on I’ll be scattering backups like Easter eggs!

1 Like

Really sad that a file can get corrupted so badly (unrepairable) and you don’t have a backup of the plain text or previous save…

I wrote that thinking the whole file is corrupted due to zip format (one bit ruins everything) but I’m probably wrong and zips can recover from mild damage just like CDs?

ZIPs can be recovered from 1-byte damage somewhat: it is not guaranteed that it would restore everything, but no 1-byte damage would make ZIP totally alien to any restore utility.

Yours is not such case; in all ODF files, there would be at least the usual ZIP header (starting with PK bytes), then after the header, there goes a mimetype file stored without compression (so you may read it using notepad; e.g., it may read mimetypeapplication/vnd.oasis.opendocument.text)…

In that case, are you lucky enough to have a working copy in Volume Shadow Copy?