Office writer runs slower than molasses in the middle of winter

Ok, I am at work with a new computer Dell OptiPlex 7090 16GRam. It comes with Microsoft Office but I installed the latest LibreOpenOffice software (x64) LibreOffice Community. :innocent:

It is painfully slow on this computer. I try just to click to place the cursor and it will take 10-20 seconds to respond to me. This is not useful, so I check the web and Tools-Options-Memory is the web displayed fix -BUT Memory is not there as a pull down any longer. (I wonder why, or where did Memory get moved to???) :pouting_cat:

Now what do I do? None of the internet fix options are valid for the latest versions.

Please help, I love LibreOffice, but it’s just not useable. How can I speed up LibreOffice? What is wrong? :disappointed_relieved:

Thanks in advance for your help.

…Prof Scott :man_student:

It comes with Microsoft Office

If you have MS Office, I assume you have Windows 10 or 11 as your operating system.

Then you have the possibility to call the task manager with Ctrl+Alt+Del. Check which processes use a lot of CPU and memory. Is it really LibreOffice?

You may also have a virus scanner that prevents you from working quickly. There is a list of problem areas to look out for. Have a look yourself:

General Installation Issues (Windows)

With a new PC with Windows operating system, Microsoft also provides a lot of unnecessary apps.
You can uninstall some apps that you don’t need.


Was a feature that allowed you to determine how much RAM (of the existing) you wanted to allow LibreOffice.
It is a deprecated feature that, as with you having 16GB of RAM, is by no means needed anymore. It was removed many LibreOffice versions ago as it is unnecessary.
You can conclude that LibreOffice is always being developed further. The best remains.

…it will take 10-20 seconds…

I can assure you that this is not normal.
With me there are virtually no delays:

Version: (x64) / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

1 Like

…definately not normal
enable OpenCL in options?
enable/disbale Skia in options?

you say a work computer?, maybe LO is not in fact installed locally, or your account acceses LO differnetly to MSoffice or some other such account/security/firewall etc related issue?