Offline help files assigned to wrong app

LO offline help is not working. After installing the offline help, I mistakenly chose calc as the app to display the HTML help files. Now, after uninstalling and reinstalling LO and LO offline help, I’m still not given the option to choose a browser to display help files, and F1 does nothing. How do I change the configuration so offline help will be displayed in a browser?


I am assuming that you have Windows 10 because that seems to be the only operating system that keeps removing your file association defaults.

If you go to C:\Program Files\LibreOffice\help does it show a Calc icon against help.html? If it does then you need to change the default association back to your browser. You can do this by right-clicking on help.html, select Open With > choose another app , in the window that opens, select your browser and tick the box that says Always use this app to open .html files.

Yes, Win 10, and help.html is associated with a browser, but when I open it I see a url with a nonexistent path:


There is no “latest” directory. under C:/Program%20Files/LibreOffice/help

On mine double-clicking Index.html, in the same directory, opens help. I just used the first html file I saw as example because I thought it might be an association thing. Probably happened because Windows updates also often remove your default browser preference and LO didn’t know which browser to choose.

Resetting your user profile might return everything to factory setting assuming it is a user setting but if it is an All-user setting then it wouldn’t. You would lose personalisations like autocorrect words added, etc.

It is probably just one line somewhere; sadly, I don’t where, sorry. Al

Thanks - resetting the user profile didn’t help, but if I open index.htm, help does open. I edited the path in help.html and it also now works, but help inside of LO still doesn’t work.

Somewhat in your browser there should be a setting to make that browser the default, try that

Yes, the browser is already set to as the default for html - but the help files don’t open at all when in LO. the help files do display in the browser if I open them from windows file explorer.

I am having the same problem with LO on ubuntu 18.04. I removed my user profile, reinstalled LO and LO help, but LO help opens signal-desktop. I removed signal-desktop and got the help to open in my default browser Firefox 81.0. When I reinstall signal-desktop, the same problem - hitting F1 in LO or choosing help from help menu takes me to signal-desktop.

This was a nautilus problem. All my html files were associated with signal-desktop. Weird. Cannot remove the association through “open with”. Instead from nautilus go to file properties and change the default open with there.