Offline Help Package

Offline Help Package. I removed an older version of LO and downloaded vs 7.2.6 (LibreOffice_7.2.6_Win_x86.msi)along with the help pkg (LibreOffice_7.2.6_Win_x86_helppack_en-US.msi) both are English and 32 bit. The HELP pkg. don’t open it still goes online.

@Hrbrgr’s answer is most possibly correct; however, just to make it clear:

You didn’t mention what “English” might mean here. It’s obvious that your help package is English (USA); but there’s nothing in your question that allows to see what UI language is chosen in your LibreOffice itself (if you copied full data from Help|About, it would clarify that - indeed, you always do so when ask for help anywhere, and just somehow overlooked it now by mistake?). It could be e.g. English (UK) or English (NZ)?

The English pkg. I downloaded makes no difference. My problem isn’t that I don’t understand the answers I get from the Offline Help; my problem is, is that I don’t get any reply when I press F1 or click on help.

You must make sure that the program and the helppack have the same bit number (both 32-bit or both 64-bit) and the exact same LibreOffice version number. 64-bit, of course, only if your computer is a 64-bit system.
And both must be installed.
If you press F1 now, see my answer…

Here’s a sample of a selection I pulled here from:
C:\Program Files\LibreOffice\help\en-US\text\scalc\00
every file in this folder has this extension *.html

Probably best to clarify a little. Old Help files were in a special format such as chm that opened a special reader. Help files now are html and open in the default internet browser. Many apps, e.g. MS Office, use this functionality to open an online page; no internet = no help. LibreOffice offers a download that installs the offline files, these still open in a browser. The only way to tell is to look at the address in the browser.
Online Help
OnlineHelp


Offline Help
OfflineHelp

Now for the tricky part. I now have to make sure that I download the Help for my installation, in my case en-GB and 64 bit. If I install the en-US help I will not get offline help and maybe because there is help installed it no longer calls the online help. The same occurs if I download a 32-bit version of Help.

You have to make sure it all matches, so 32 bit and en-GB, en-ZA, or en-US depending on what you downloaded when you installed LibreOffice

1 Like

…it still goes online

That is’nt right. Please look in your internet browser at the top of the address, it starts with “file:///”. That means from your computer. The offline help has been changed accordingly.

I’m puzzled why LibreOffice doesn’t simply load and display the Help file since it clearly knows where the file is located, and it’s a html file, too. But we users are made to stumble through the Help file maze, and search through this software puzzle just to locate what should be simple “How-to” notes. Is it not possible for LibreOffice to display these Forum Q&A’s to simplify the Help loading process? If the unfortunate LO user doesn’t stumble onto this page, he’ll never find simple answers that he’s entitled to see.

LO’s sponsors need to remember that there’s no textbooks on using LO (nor OpenOffice) and much of LO is really obscure and complicated for the average user (like myself).

See the guides listed here English documentation | LibreOffice Documentation - LibreOffice User Guides

When you download LibreOffice from LibreOffice.org you are offered the matching help file to download at the same time

1 Like

Interesting! In the decades I’ve been using OpenOffice and LibreOffice, I’ve never succeeded with implementing a “matching help file”. With your encouragement, I’ve tried again today with no success. Downloaded LO v7.4 + Help 7.4, up from 7.3. Help only opens an html file in Notepad. Searching through the html, I see “&System=WIN&Version=7.4”, so am I right in assuming this is a match for my LO 7.4? I can get it running by fiddling with it as an outside website. So how this works is: every time I want to look up a how-to detail, I have to get this file running in a browser which is tedious and time-consuming. It would be much easier if it worked as an integral part of LO. Or am I wrong?

This means that LibreOffice help is installed and detected correctly, and it’s your system configuration that defines notepad as default application for HTML files. It is expected that HTMLs are opened in browsers.

I agree with mikekaganski that it is your operating system configuration that has been altered, probably inadvertently sometime in the past. In Windows 11 (similar in Windows 10), here is one way to set the browser back to its default to open .html files:

  • Click Windows Start Menu > Settings > Apps > Default Apps
  • In the Settings window that is open, in the top field shown with a magnifying glass enter .html and select it from the list. It will show the default app to open .html files, in your case it will be Notepad as shown below
  • Click the square icon at the right of Notepad to see a list of apps from which to choose the default, see cursor in image above.
  • A new dialogue will open, from there choose your preferred web browser. In the image below I have chosen Firefox. Then click the button Set default and your system is back the same as everyone else’s.

If you have Windows 7 (also works with 10 and 11) then you can:

  • First make sure that you can see the extension for files. In Windows Explorer click on Tools in the menu bar
    • Select Folder options
    • Click on View Tab
    • Uncheck Hide extensions for known file types then OK to exit
  • Find a file in File Explorer with the extension .html and right-click on it and select Open with > Choose another app.
  • A new dialogue will open. Select your preferred web browser from the list and then click the button Always use this app (or similar wording)

It is expected that HTMLs are opened in browsers.

Ah, that explains this issue. It’s a fundamental design error. HTML files are not always viewed by a browser. Anyone who edits software will set HTML files (as opposed to URLs) to open by default in an editor, e.g. Notepad. This is usually not a problem if one knows where to find the HTML file because it can be saved and run in a browser later. However, in this case, the HTML file originates somewhere else so it must be saved locally, to be opened later by a local browser. I have no idea where OO’s files are located (they don’t come as a URL), so I must copy/save it as a local file. Now that I know what’s happening, I can work out a kludge. It’s very unusual that an application would be directly serving naked HTML files to a user, i.e. without the file’s URL. Most of OO’s other tools are served as URLs, but this one, for some unexplained reason, comes as a file. A very clumsy arrangement, indeed!

I’ve since found that further down the Help Page, there’s a “Help” page available served with proper URLs. However, it doesn’t appear to have any useful information. I’m curious why OO Help remains such a thoughtless presentation! Thanks for all the work you’ve done to help me figure out this eminently clueless Help tool!

In which case they should know they have done this.

Obviously not, the average user does not edit software.

2 Likes

Anyone but me. I view more html-files than edit, so i use right-click to edit with notepad++.
And for bigger projects I start first the Code-Editor an manage then my project-tree.
.
And maybe there are other people out there, wich don’t follow your “rule”. You could use a html-editor with a preview-tab to have the file usable…

Agree. Windows has this design error in its ShellExecuteExW API, which accepts file URLs, but converts them to system filepaths internally. You definitely need to file a respective bug report to Microsoft.

And I bet that “anyone who edits software and will set HTML files (as opposed to URL s) to open by default in an editor, e.g. Notepad” (huh? does “anyone who edits software” - nice verb BTW - necessarily mean “edits HTML”?) and uses Windows, would know this limitation of the OS, that you simply can’t distinguish file URLs from file paths when working from shell (like executing default system open action on such file URLs)…

1 Like

Uh, thanks, Mike! I’m just a simple end-user, not an LO developer with no kids and lots of spare time and nothing to do! Do you have any more useful suggestions?

Why are you complaining here about bugs in your OS then? You implied that LibreOffice behaves wrong. It turns out it’s your own uncommon setup makes it so; and then you say that something (that is defined in the OS) is architectured fundamentally wrong. You had been given specific pointers. You do not want to act on that accordingly. My next more useful suggestion is - live with that of fix your setup.

Note that the OS provides different actions - e.g., edit vs. open; and making open act like edit is a fundamental user error.

Jeez, you guys are so awesomely useful! Without your suggestions I never would have thought that I should reorganize my entire existence to view these clueless LO Help tools!

Mike, you’re slow to pick up on what’s going on. I’m the customer, looking for useful help. I’m not sure where you fit into this conversation, or where you came from. I’m especially not sure what is your purpose being here.