onedrive for business vs invalid char of lock file


I use windows 8.1 and onedrive for business. I have a folder in my pc that sync with onedrive for business. Everytime I open a file that is stored in this folder, the lock file is created and onedrive popup a message “Name: .~lock.myfile.xlsx# / Error: the name or type isn’t allowed. Resolution: remove the item from your OndeDrive folder. For info…”.

The problem is invalid characters in file name: “~” and “#”.

This link explains these limitations for file name:

How can I get a solution for this invalid characteres?

Carlos Sato

Related information: Disable file locking in LibreOffice on Windows - #5 by oweng

edited 20160621

Maybe Microsoft doesn’t want the people working directly on OneDrive with desktop app, if I’m not wrong even the MSOffice lock files has a “~”, perhaps their cloud programs use different names or mechanism to lock.

I saw these posts. None can help me.

Onedrive doesn’t accept chars “~” and “#” in the file name.

I don’t want to disable “lock system”. I think the LO should have another way to set the file name for the lock system to allow work on the onedrive synchronized folders.

Have you ask to Onedrive why they don’t allow those characters?

did you found any solution?
It is very confusing for general user to receive the system message that the file could not be saved.