OneDrive not connecting

So I am trying to connect to OneDrive remotely in the latest version of LibreOffice. I paste in the URL that I am redirected to, but the message i get is “The specified device is invalid.” What am I doing wrong?

What is …

…the latest version of LibreOffice

Define as, e.g. or others.

Which OS do you use?

This is version in macOS 10.14.5

As a Windows user, I leave an answer to someone with a mac system.


Don’t believe this has worked for some time now. See tdf#62437

OneDrive and Google Drive are not connecting for me either under Windows 10
Version: (x64)
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win;
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded


In addition to the OneDrive tdf, there are a number of bug reports concerning Google Drive such as tdf#101630

This subject has also come up in this site many times. Hasn’t worked in some time.

Believe me I know, I commented on one of the Google Drive threads.

So how long has this been an issue, and has the team at Libre offered any news about when it will be fixed?


As mentioned in other comments (with Bug links) has been outstanding for some time. It will be fixed (as all Bug reports are) when there is a volunteer that is willing to find the problem and submit the fix. You are welcome to do so.