Open PDF Why font substitution when fonts are installed?

I have an accounting app that I use to generate invoices I eMail to clients. Occasionally, I have a need to edit the text of the PDFs without regenerating an invoice. I’ve been using PDF Element Pro but decided to give LibreOffice a try using the Draw module. The PDF open right up but any elements that were crafted using Arial or Arial Black get changed to Liberation Sans and Liberation Serif (and this substitution isn’t consistent; sometimes they swap Sans for Serif and vice versa). I’ve created a font substitution table telling LO to use Arial and Arial Black in place of Liberation Sans and Serif (two entries in the table) “always” (which apparently means both on screen and when printed). But this substitution table worked once and then fails consistently.

Arial and Arial Bold are installed in my system (Windows 10) so there shouldn’t be any sort of substitution. I’ve tried changing the fonts used by the accounting app but, regardless of what I choose, it appears that LO uses the two Liberation fonts.

Do I need to install an extra copy of the Arial font family in some special location that LO will notice when it launches?


That looks like a bug … which you are advised to file (with a sample PDF), if it appears in current versions (you didn’t mention LO version you use).

O-ho! The plot thickens. When I opened an older PDF I had created on my Mac (using the Mac version of the accounting app and with the Mac app Preview as the PDF-creation engine), the fonts appeared exactly as expected, yet they are identified as “Liberation…”. (Correction: Once, the font name “Liberation…” appeared and, within a few seconds, spontaneously changed to “Arial” (not Arial Black) but the name was italic. Clicking away then back showed the “Liberation…” name again.

I opened both the older PDF & one of the new ones (created in Windows) in Wordpad and found that the word “Arial” appears in the older (Mac-gen’d) PDF but is missing in the newer (Windows-gen’d) PDF. In addition, the Windows PDF (using Wondershare PDF Element Pro’s driver) shows “pdf1.4” while the Microsoft PDF (and the older PDFs created on my Mac) show “pdf1.7”. I did try embedding the TT font in the “Advanced” settings of the PDF Element driver but that made no difference. Can’t embed with MS’ driver

This is a continuation of my last comment…

Mike, it does appear this is a bug in LO (I’m running in the Draw module). I’m not dead in the water as the newer PDFs (generated in Windows by MS’ or Wondershare’s driver) open properly in in PDF Element Pro (and may be edited just fine). As well, I can drop any of the PDFs (older Mac or newer Windows) into a Chrome browser window and the PDF appears exactly as expected (although not editable, of course).

I’ll try to get a bug report generated and include some of my PDFs and screenshots.