Opening LibreOffice, opens the LibreOffice Document Recovery Box

I’m running Windows 10, the download was ’ LibreOffice 5.1.1 for Windows ’
LibreOffice has been running well since I downloaded the version in 2014. Two days ago it stopped working. I downloaded 5.1.1 hoping the problem would be fixed.

The problem is:

  • Click on LibreOffice.
  • LibreOffice Document Recovery window opens
  • Message: Document Name - Untitled 1 Status - not recovered yet.
  • Press the button labelled [Start Recovery]
  • Message: Document Name - Untitled 1 Status - Successfully recovered.
  • Pressed the [Finished] button.
  • A blank screen appears with a Load Document message and a Green Bar
  • The X in the top right corner of the screen. A red box appears behind it.
  • The screen dulls and a spinning blue O appears.
  • LibreOffice stops responding.

I tried using the program compatibility in Windows / Properties, but that didn’t help.

Instead of recovery, choose discard recovery data. You will lose the file though.

This happens because there’s a hidden file named “~.lock” that is placed in the same folder of your last file edited. If you get rid of that file, the problem will be solved.
So enable “Show hidden files” and look up for that file. It will have the same title as the file you were editing but it will end in “.lock”. Delete it or send it to Rubbish Bin. Then log out and log in. LibreOffice now should work fine.

After writing this problem, I found that I couldn’t print any file. After hours of looking for the answer, I found one which solved my problem.

I went to msconfig (System Configuration)

  • under the Services tab click the box “Hide all Microsoft services”
  • Click “Disable”
  • Open the tab “Startup”
  • click on the link “Open Task Manager”
  • Click on the “Startup” tab
  • Disable all the programs listed

After a few hours of use now, I haven’t had any problems. I don’t know if this is a permanent solution.