Opening LibreOffice7.2

I have been using LibreOffice7.2 successfully for 3 years but now it wont open. I have looked for solutions online & advice is to open in safe mode & amend settings to deselect Skia. However it wont even open in safe mode. Is there anything else I can do please?

Is there anything else I can do please?

First tell us your operating system please.

Thx for quick response. It’s Windows 10

Thank you for your information.

  • Have you done a LibreOffice update?
  • Have you done all the necessary updates of Windows?
  • How are you trying to open LibreOffice (taskbar, desktop, other-how)?
  • Do you get an error message?

You can look in Windows in the Control Panel>Programs&Features.
In my case, the programme has 819 MB and the Helppack 28.3 MB.
Maybe right-click on the programme and select “Repair”, then the Helppack.
Then try to start LibreOffice.
Please report back here. Thank you.

And please remember, we can’t look over your shoulder, that’s why we need detailed and exact information. Thank you.

With me:

Version: (x64) / LibreOffice Community
Build ID: 184fe81b8c8c30d8b5082578aee2fed2ea847c01
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

Thank you for your reply. Here are my further comments:
I haven’t done a libre update - I tend to rely on the “automatic updates” facility.
I am still using Windows 10 which I have installed with an overlay “Classic Shell” which I understand only affects the visual presentation rather than functions of the O/S.
I have tried opening Libre Office from desk top, taskbar, and from the Start > Programs menu. I have tried both Libra and Libra Safe Mode. In all instances I get no response to my “click”.
When I go to Control Panel>Progs & Features I see Libra & 716 mb. I have selected Repair and get an error message as attached. When I click on the dropdown for selection of the source the only other option that shows is 1 which appears to be invalid.

I don’t know if I am imagining this but my problems seem to have coincided with installation of Norton Security at the behest of my ISP - Plusnet who have recently switched from McAfee to Norton for their service included in my contract.

I do appreciate your assistance
many thanks

EDIT @Hrbrgr , cut for the center:


That may well be and you might have to tell that snake oil thing to allow LibreOffice to run.

However, the message in the screenshot just tells that the original LibreOffice installation packet is not available on your machine anymore, if needed you could download that specific 7.2.7 .msi from the archives (you might have to rename it to LibreOffice_7.2.7_Win_x64.msi to match the exact file name the dialog indicates). I find it odd though that the directory says C:\ProgramData\Norton\... instead of some Windows system path, but then again I don’t know anything about Windows and even less about Norton snake oil.

Note that there is no automatic updates for LibreOffice packages from TDF (e.g., installed from MSI). So your installed version will never auto-update itself, unless you do that manually (it will notify you about existing new versions, however).

I see you have a Windows Update waiting to complete. I would not do anything more until Windows Update has installed and you have restarted Windows at least once, preferably twice.

After that I would definitely find out how to add LibreOffice (soffice.bin) to an Allowed list in Norton.

1 Like