Outline Style Inserts Line Break Between Number and Text. How do I fix?

Hello, all. I am learning LibreOffice Writer

I created some custom outline Heading styles… and everything was working great.

BUT I must have accidentally changed something because when I opened my document a few days later, all the outline Headings now had a line break inserted between the outline number and the heading text… like this:

Heading 1.

    Heading 2

                Heading 3

I have looked at the style settings, but don’t see where to fix this. Does anyone know what happened??

How can I fix this so that the heading text is on the same line as the outline number?


Please, we need to know your operating system.
And upload a reduced and anonymized file here so that someone can examine it.

Hi, Hrbrgr.

I am using Windows 10 Pro, version 22H2.

I have also attached a copy of this file that has been reduced. (Note: I chose to save all my files with the .docx extension for compatibility).

On page 2, you can see where the styles are inserting a line break after the outline number.

Thanks so much for your assistance!
Demo.docx (16.0 KB)

The .docx was developed for INCOMPATIBILITY by the MS. It has two versions: the Strict one and the Transitional one. The MS Office uses the Transitional one since the beginning. And the MS continously changes that version.
Never store your important documents in foreign file formats. Use the native, international ODF file formats.
(You can export a copy at end of editing into the other file formats, but you always will lose some formatting properties and/or even some contents…)

1 Like

THANKS for the information, Zizi64… I will change the file format going forward.

However, I changed that setting months ago, so I don’t think it caused my style problem.

Your Tools>Chapter Numbering, Position tab settings are simply inconsistent.

  • Aligned sets is the position of the number
  • Indent at is the left “margin” of the heading paragraph (except for the first line because it is “continuous” with the number)
  • Tab stop at will be used on the first line to start the heading

Consequently, you should set Tab stop at equal to Indent at to get a homogeneous heading even in the case where it needs several lines.

By setting Tab stop at 0, there is no available tab stop when the Tab is met and subsequent text is sent to next line. By setting Aligned at equal to Indent at, your number is located “inside” the heading instead of outdenting at left and you also create a similar condition with tab stops.

To summarize, here are corrected settings:

Level Aligned at Indent at/Tab stop at
1 0 1.27cm
2 1.27cm 2.54cm
3 2.54cm 3.81cm
4 3.81cm 5.08cm

THANK YOU, ajlittoz! I have no idea how those settings got changed but fixing this solved my problem. Again… many thanks! :grinning:

Have a look at:
Tools → Chapter Numbering…

2023-01-07 07 02 46

Version: (x86) / LibreOffice Community
Build ID: 382eef1f22670f7f4118c8c2dd222ec7ad009daf
CPU threads: 8; OS: Windows 10.0 Build 22621; UI render: Skia/Raster; VCL: win
Locale: en-GB (de_DE); UI: en-US
Calc: threaded

1 Like

Thanks, PKG, for the tip. But, unfortunately, the number is followed by a “Tab” space.