Package missing / Can't update LibreOffice

I recently tried to update to the latest version of LibreOffice but wasn’t allowed to. I decided to disinstall the old version (5.4.1) and try again, but when I did this I was informed that disinstallation package LibreOffice_5.4.1_Win_x64.msi was missing. Please can you help me find this package so that I can disinstall the old LibreOffice and update to the new version. Many thanks in advance.

Try to rename LibreOffice_5.4.1.1_Win_x64.msi to LibreOffice_5.4.1._Win_x64.msi (skip the second .1) and start again.

You can find older LibreOffice versions in the archive.

OK I went to the archive and I downloaded LibreOffice_5.4.1.1_Win_x64.msi, but when I tried to install it I got this error message: Error 1714 the older version of LibreOffice cannot be removed. Contact your technical support group.

This is exactly the same message I got when I tried to update to LibreOffice 6.2.

My computer can’t seem to find the installation package ‘LibreOffice_5.4.1_Win_x64.msi’ which it needs to complete.

Yes that’s got it. Many thanks for all your help.